Sharp x68000 (Pk68k core) Retroarch 1.9.14 It doesn't work

I’m trying to launch a game in m3u, dim, xdf, hdf format, but it doesn’t work. Does it happen to someone else?

1 Like

Could you post a log? I have no issues running dim files.

Do you have the required BIOS in the “retroarch/system/keropi” folder?

I have had no luck running multi disk games using m3u. I have curated only single disk games for my rom collection.

Yes, i have the BIOS in system/keropi Folder. I have all bios:

Here my log: https://pastebin.com/ZLWYnJqY

1 Like

Have you had it running on a previous version of retroarch?

I ask because I see some stuff about the bios in my log.

[libretro INFO] Parsing arguments ...
[libretro INFO] 0 : px68k
[libretro INFO] 1 : E:\Emulation New\Sharp x68000\Akazukin Cha Cha Cha v1.04 (1995)(Sprite).dim
[libretro INFO] PX68K Ver."0.15+"
[libretro INFO] Libretro...
[libretro INFO] D:\Games\RetroArch 1.9.7\system\keropi
[libretro INFO] cur_dir_str c:\ 3
[libretro INFO] fp:376183456 (iplrom.dat)
[libretro INFO] R: f800, G: 7e0, B: 1f
[libretro INFO] Restarting PX68K...
[libretro INFO] INIT done
[libretro INFO] CPU Clock: 10MHz
[libretro INFO] RAM Size: 2MB
[libretro INFO] TextDotX: 768
[libretro INFO] TextDotY: 512

If you have never had it running maybe you have a bad bios.

Yes, I have tried RetroArch in previous versions and it works perfectly, but it does not work in the latest versions.

Can you try the latest version of RetroArch? Maybe it works for you.

I’ve been testing different versions of RetroArch, and it doesn’t work from version 1.9.11 onwards. The files in m3u also work perfectly for me.

1 Like

I am running 1.9.12 and it works. Have you tried a fresh install and/or updating your core info files.

Try an older version of the core. The latest one does not work for me. A 2 month old version does.

4 Likes

Thank you. That way it worked for me. I currently use Retroarch 1.9.14 version with the older PK68K core.

2 Likes

same here, I’m using an old version of the core.

2 Likes

Hello, There was a problem with the current core, I’m using an old one. Here the link:

https://buildbot.libretro.com/stable/1.9.9/windows/x86_64/RetroArch_cores.7z

Just take the file “px68k_libretro.dlI” (folder “core” from the link) and replace the one in the folder “core” in the main folder of your Retroarch (which you use).

I wanted to report this Sharp X86K issue to Retroarch developers, but I don’t know where to do it. If anyone knows, please help me.

2 Likes

I used the option to lock this core with the old version that still works. It will probably get fixed in the near future, but since it works fine for now, this is a good solution.