Shield TV remote no longer works

Shield TV remote always worked before the last couple updates now it doesn’t. It detects it but none of the buttons work. Anyone know how to fix it?

Can you identify when it broke? That is, does reverting to an earlier RetroArch version restore the functionality?

It stopped working on the first RetroArch 1.7.8 (before the couple of GIT updates on Google Play store). It detects it but none of the buttons work. Speaking of which my USB SNES controller also had to be completely remapped to work correctly with this update, so it might be a related button mapping issue. I even tried a clean install and downloaded controller profiles with Online Updater. Remote still won’t work after all that other than just being detected when the app opens.

This is on my Nvidia Shield TV running the latest Android 9.0 update. If there was an easy way to submit my controller profile to the RetroArch team I would do it to help others.

edit: I’m wondering if it’s related to this post: New gamepad autoconf process

As I recall, the remote has to be handled in a specific, hardcoded way. There were some input changes a while back, though, and the remote stuff may need to be updated to match.

That must be it then. That’s about the time my USB SNES controller stopped binding the correct keys and I had to do all the binds manually. There should be a way to submit the bind profiles to the RetroArch team so they could be integrated into the controller profile file.

to confirm… this is still broken… on a new clean build retroarch on shield tv doesn’t seem to work for any bluetooth devices correctly. The remote and a 8bitdo sn30 pro controller say they are corrected but they do not map to any functionality. If directly plugin the 8bitdo sn30 pro to a usb port it works fine. So, it sounds more like a core bug then just a mapping issue.

Hi,

I have the same issue, my PS4 controller is not working either. Even the menu is unusable.

If someone has a fix !

Just got my Shield Pro 2019 and installed RetroArch - it loads up, but neither the remote or the nVidia controller will operate any of the menus.

Obviously different kit, but it loads fine on my OnePlus 7T Pro phone using Android 10.

Any ideas? Thanks

1 Like

I have been having the exact same issue with this exact thing on my new Shield pro 2019. No controller works. Is there anything that can be done to fix this?

Mine is working now.

Force Close RetroArch. Open it, but do not use the Shield remote. Use your Shield Controller instead - it then works. If you try to navigate the menus using the Shield remote, it will cock-block the controller.

1 Like