Single controller moves multiple players

controller

#1

Hello everyone!

First, I apologize if there is a post discussing this issue. I feel like a fool having this problem and not being able to figure out the solition :frowning:

Hardware I use is Android box MX10, cuad core, 4gb Ram (works perfect). I have 4 controllers, two Bluetooth and 2 wired. All of them seems to work.

Now, when I try to configure/map the buttons, this is what I do:

  1. Open retroarch
  2. Connect 2 controls (either wired or not)
  3. Get into settings and select 2 controllers max
  4. Map buttons from each of them, one by one. So far, so good
  5. Now, I close it and open DIG (frontend) in android and open one multiplayer game
  6. There is a whole deal with the control being used. Only one of them works but seems Retroarch is mocking on me as if I pick one, it will configure the other one and the other way around. Annoying issue.
  7. Finally, once I find the control which works (assume player 1), I select 2 players
  8. Once in the game, the working control moves both players and the second control doesn’t work at all!

The other annoying problem is that I can’t get out of the game. I have configured hotkeys but they don’t work. It is not intuitive.

I really want to play with my 8 year old son and so far, I was not able to :frowning:

Thanks a lot for your help! Alex.


#2

Go to settings > input > p2 input binds and change the device index to the other connected controller.


#3

Hello. Thanks for your response! Ok, i tried that and it does makes sense. I saved before restarting retroarch but when I start it again I have to press strart on both controllers to set the index #1 and #2. Now, when i get into the game, even though o see the message in yellow saying both were detected (index 0 and 1), the seccond controller isnt and both players moves with the controller 0.

What is weird is that if I press strart on controller A once in the game, the controller B is the one that became active.

Bottom line, still not working :frowning:


#4

Ok, I was able to make it work but painfully.

As mentioned, DIG is the Android Frontend I’m using. I guessed (correctly) that the configuration was not being loaded properly when I used it.

The way to fix it was to open Retroarch, make sure both controls were enabled and then start the games from there which is not too user friendly.

Any other suggestions? Apparently DIG is not loading the retroarch config file or something?


#5

I’m afraid I don’t have any advice for dealing with any launchers.