Slow snes emulation on Android

I’m using a HP slatebook x2, it’s old but it’s easily powerful enough, the power management is set to maximum performance

i tried all snes cores (some are obviously way harder to run, forget about those), tried threaded video, i also added and removed shaders, changed vsync, the FPS is exactly the same! when i change the audio driver from opensl to rsound, the sound goes away and the fps locks at 60, so is it a sound problem? the default audio latency is 128, i changed it to 64 and got the same result, also neogeo is the same, both snes and neogeo average 46 to 55fps with default “opensl” audio driver and 60fps with “rsound” wich mutes the game

other snes emulators work fine, also n64 runs fine on other emulators at 1080p but i don’t expect to be able to play it on retroarch, it’s just a reference

1 Like

If you’re using the Beetle SNES Cores, they are all based on Higan/BSNES. Those cores have higher resource requirements to run fullspeed. Your best bet is to use the SNES9x cores, but if you’ve already tried those, then …:frowning:

yes, i tried all of them :frowning: this is just such an unheard of hardware, hopefully someone know something

Try to disable Audio Sync.

Also try NeoGeo in some other core (i assume you use FBA). Usually Mame is more reliable in terms of audio/video sync. Try Mame 2003 as it should work full speed on your device.

i think i tried disabling audio sync, where is this option? i’ll try when i get home

neogeo i used mame2003, it’s the core that worked actually, i’ll try a very old arcade game and see what happens

all the same, same fps in all conditions

tried installing an older version of retroarch, didn improve at all

Did you try a standalone emulator, like Mame4all (i think it has the same mame2003 romset)? Try neogeo there, for comparison.

Also, in Retroarch try Vulkan video driver. For me, it is a big improvement in some games/cores in term of framerate stability.

i tried standalone snes emulator and it was good, even n64 was good, i’ll try standalone mame tonight!

vulkan crashes retroarch, my device probably doesn’t support it

MAME4droid 1.5.2 downloaded from the playstore worked flawlessly, can play metal slug just fine

i tried final burn neo with marvel vs capcom, it has a frameskip under core options, i tried from 0 to 5 and you can see the frame skip but it still lags somehow, kinda crazy

Look into the other options under the “latency” menu. Do a little trial an error with each one.

I have a gpd xd and in some snes games like stone warriors it goes slow I don’t know why

I am facing the same issues on an old android phone. When on opensl i have stuttering on snes-Megadrive at 45-55 fps, when i switch to rsound i have no sound and both work locked at 60 fps (genesis plus gx and snes9x 2005 plus). The same core genesis plus gx runs ok when it runs sms games. Probably not powerful enough to run opensl? Other emulators like stella 2014 run fine on opensl

i found what was going on, i had to manually set the refresh rate of the screen, i knew from standalone emulators that it was 58.92, so i entered it manually in video-output and everything is butter smooth now.