SNES controller no longer working


I am new to RetroArch. I had just recently downloaded the program and I got a Mayflash SNES to PC adapter in order to play some games. At first when I plugged in the adapter, RetroArch read the adapter as a Mayflash adapter. I then switched my input layout to fit my SNES button layout and when I played Donkey Kong Country 2 everything was fine.

But the next day, I tried to play the same game but my controls were not working. So I went to reinput my controller in the Input settings again and noticed that my adapter was no longer being read as Mayflash, it showed up as USB GamePad. Once I input the buttons to the respected layout of my controller, I tried to play the game once again but for some reason my A, B, X, Y controllers are not only doing there functions of what they are suppose to do, like jump, roll/run, toss, and crouch but they are also acting as the D-Pad as well where the Y-button will move me right, B-button will move me up, X-button will move me left, A-button will move me down. So if I wanted to run back I would not be able to since I would need to hold down the Y button to run but it will also caused me to move right making it impossible to move left. It did not only happen to this game I tried other games as well and they all have this problem. Even in the home screen of RetroArch it will not work properly.

Is there a way to fix this?

I am currently using RetroArch version 1.8.1 on Windows 10 My specs are i7-7700K 16 GB Ram 1080 Graphics Card

Heres the adapter I bought from Amazon:

Feel free to ask me questions if I was not able to clarify my problem.