SNES Cores Update for Tengai Makyou Zero Patch v3.0

Sorry if this is the wrong place but this is mostly asking if the SNES cores can be updated for Tengai Makyou Zero to work with the v3.0 patch since there are quite a number of changes from v1.0 that prevents it from working anymore on the older cores.

1 Like

Which cores does it not work in?

i have been trying get the rom to work and its a mess!. Some cores need a bml, other cores need a xml and other core need a splitter for the romfile… i give up. (i use bsnes mercury) I wait for someone want to share the working rom

No problem here, using 3.0 ips patch, no-intro rom and the latest Snes9X core.

1 Like

There was no explanation on how to make it work in the thread, so I had to try until it finally works. I prefer using SNES9x, since it won’t need to load BML or XML files, just the main rom, so this is what I did to get the game to work.

The patch read me says:

Not all emulators can run the patched version of the game, but the translation does work on actual hardware. (Flash carts won’t run it, but it’s possible to modify the actual cart.)

Several emulators can run the game, including Higan (which requires the .bml and the use of the included rom splitting program), bsnes (which requires the .xml), and recent versions of snes9x. Snes9X does not require a .xml or .bml, and when Higan v107+ is released, it will not require it either.

If you’re using Higan, please use DDStranslation’s file splitter tool after patching the rom, and add the folder it creates to Higan’s main folder. Be sure to add the .bml file to that folder. Apparently, the file splitter may not be required once Higan is updated further!

If you’re using a version of the bsnes emulator that requires .xml files, you must place the included .xml file in the same folder that the rom is in, with the same name as the rom (you don’t need to use the splitter). If you do not do this, you will not be able to pass the game’s two initialization screens.

Some emulators have problems with the real time clock’s date display. That is a fault of the emulator, not the patch. To get around it, simply change to a different emulator or version. If the emulator of your choice does not support the English patched version of the game, I suggest that you contact the author of the emulator and ask them to add support for it.

Once patched, the game must run through an initialization process the very first time you start it. Press the A Button, then reset when you’re prompted. A similar screen will appear. Press the B Button this time, then reset when you’re prompted. The game should begin then.

So, with the V3 patched original Tengai Makyou Zero (Japan), I have opened Retroarch, loaded content (Tengai Makyou Zero (Japan).sfc) with the latest SNES9x core, it will show this screen:

Tengai Makyou Zero Japan 180128 210007

Press the assigned SNES gamepad button A in your gamepad or keyboard (default is Z), it will now show this one:

Tengai Makyou Zero Japan 180128 210015

Enter Retroarch’s menu pressing F1 or your custom menu button and hit “Restart”, it will reset the content and show this screen Again, but now press your assigned B button corresponding the SNES gamepad: Tengai Makyou Zero Japan 180128 210007

And it will go to this screen: Tengai Makyou Zero Japan 180128 210038

Restart your content again like the first time, it will then show this again Tengai Makyou Zero Japan 180128 210051

Press B, it will show this… Tengai Makyou Zero Japan 180128 210107

Now the thing starts to make sense, once you restart for the third time, you’ll actually watch the game booting, thankfully the first steps won’t be needed once you turn everything off and open this game again, it will create the save or whatever file it needs and the game will now start as any other.


Tengai Makyou Zero Japan 180128 210114


Tengai Makyou Zero Japan 180128 204940


Tengai Makyou Zero Japan 180128 205050

Tengai Makyou Zero Japan 180128 205110

Let me know if this helped you guys, don’t lose hope, try again with this little guide.


I tried it on SNES9x 2005 on the Vita and it doesn’t work so I’m assuming it doesn’t work on any that isn’t SNES9x ordinary which isn’t available on the Vita.

Yeah, it doesn’t work on any of year-stamped snes9x cores, AFAIK, and that’s not likely to change, as they’re missing important parts and it’s not easy to backport those parts.

Understood, looks like I’m better off using RA on Android if I want portability since the Vita and 3DS are too weak to run the up-to-date cores.

1 Like

This sounds, ridiculous… so I am intrigued! I’ve never heard of this game. I’m gonna see what I can make happen.

@aorin1 - What shader are you using? It looks subtle, but gorgeous.

The shader is \shaders\shaders_cg\denoisers\crt-fast-bilateral-super-xbr.cgp.

I also never heard of it until that guy in OP asked about it, so I tried it today and I only needed to reset 2 times for it to create the first config file (since I had to rename the rom adding (Translated En), it needed redoing the first steps, but no more.

1 Like

Yep, totally works.

I used LunarIPS to add the .ips patch to the No-Intro, Non-shonnen-jump-edition, rom. (My roms extension was .sfc, if it matters)

Booted it up with the full SNES9x core, got the screen that said Push A, then restarted and got the screen that says Push B, then restarted again and shabooey! - Game works great.

1 Like

Sorry to bump the thread again but recently bubble2k16 was able to make Tengai Makyou Zero compatible with snes9x for the 3DS which is based on snes9x v1.43, maybe this can be looked at so it can be added to the year marked cores as only a few devices support the ordinary snes9x core.

aside from main snes9x, the other snes9x cores are heavily modified, dont think it simply matches other similar versions unlesss you really dig in or know how snes9x’ code works (or how it worked)

1 Like

I’m aware but it doesn’t hurt to have someone take a look and see if something can be done since many devices that aren’t constantly getting refreshed as PC and android it’s not possible to get good enough performance out of the main snes9x core.

Hey there,

Couple questions if anyone knows the answers to:

One: I’m running the newest version of RA on an NES classic, has anyone gotten this game to run on one?

Two: If so, what core did you use?

I ran it on regular snes9x and it let me do the first initialization but when I went to do the second half, it couldn’t initialize the RTC.

So I tried running it in snes9x 2010 and it crashed the whole system, had to do a hard power cycle to get the nes back up.

For reference I’m using the newest ips patch on a no header rom image.

Much thanks

You need current snes9x for this game.

What’s the most current version? Just regular snes9x from the mod shop?

I downloaded and installed every snes core through the current version of Hakchi2 ce

Yes, same applies for any emulator w/o a year in its name.

Well I couldn’t get it to run on any core (including snes9x) on the NES classic.

However, the first time I ran it via snes9x on a SNES classic, it initialized fine and runs a treat.

So I’m assuming that the NES classic has something different under the hood that i can’t get to emulate the RTC.

Either way, great rpg. I’m excited to finally play it after all these years. I watched the DeJap progress like a hawk and then gave up. Just recently noticed it had finally been finished.

K, my post is sorta unrelated here. Sorry! I can’t make new topics yet and I’m in need of help, plus this is the closest topic to my problem. I’m having trouble getting mGBA to work. Now, I know what I have to do. I just don’t know how to do it. When I look up tutorials on how to install GBA/GBC/GB games, they go to the retroarch store and mGBA is there with all the extra files it needs. But it’s not there on my store, so I installed it separately and it recognizes mGBA, but it doesn’t work. This is because I need gba_bios.bin, gbc_bios.bin and gb_bios.bin files, right? I just can’t find anywhere on the internet that tells me where these files are supposed to go. Any help would be appreciated! Thanks.