Snes9x core...v1.62.1

I see that there is an updated Snes9x core v1.62.1. available in the Github. I am running Retroarch via Batocera on a bootable ssd. When I update cores via Retroarch settings nothing new is found/installed. What specific files do I need to download from the Github and where should they be placed/saved?

Thank you.

1 Like

I am also waiting for this update. I hope it will appear shortly. The standalone version of Snes9x has recently been updated very often, liberto probably had it a month ago.

Those commits are almost entirely just for their own GUI/frontend, so not really applicable to libretro. It’s great that they’re doing so much work there (lots of great modernization, fixing up their Mac port, support for slang shaders, etc.) but we’re not going to sync our fork just to pull those updates in.

They do support building a libretro core from their upstream codebase, though, so you can always build that on your own in the meantime.

I’ve also seen patches for games (Virtual Bart pal version) for example. Thanks for pointing out that version 1.62.1 is on their github page. However, I hope it will be available for download via RA. For some, even small updates make a difference :slight_smile: (or on 32 bit)

and you put the dll in in your retroarch folder


overwrite the old one

the examples i gave are just for windows …

^^ oh forgot something this link

You need to lock the core to read-only, otherwise when checking for new versions, the old one will be downloaded again. The core is already done, they should put it on the server, because it’s unnecessary combination :frowning:

just want to mention that at least for me 1.62.1 dont run msu-1 games with the music (already open a issue for that)

also it seems that it has a bug thats delete saves …

1.62.2 is already out but not as core atm

For anyone wanting to do this (update currently at 1.62.3) I have figured out a method.

First of all, make sure you backup your current configuration!

Go to :-

And in the right corner you will see the “Package actions” box, click “download from mirror”. This will download the :-

libretro-snes9x-2390-1-x86_64.pkg.tar.zst file (636kb).

Now, extract this file into a new folder (I used RAR from RarLab in the PlayStore but I imagine any prog/app that supports tar files extraction will work). Inside the folder should be a “usr” folder and inside there will be two more folders. In the “lib” folder will be “libretro” and in here will be the :- file.

Copy this file into the appropriate libretro cores folder. Mine is :-


(I made a core backup and put this in a separate folder along with a direct copy of the core file. I then deleted the original).

Now restart Batocera and if you have done everything correctly Retroarch will automatically use the new version of the Snes9x core. In the “information” tab it will be displayed as Snes9x_current but it will also show that it’s the new version.

1 Like

This is frustrating!!!

After updating my core I continued to play all day without issue.

However, after a reboot, Snes9x reverts back to v1.61. Any game saves made with the new core are still showing but when I try to play they are wrong. Reloading the 1.62.3 core restores the saves correctly (phew) but reboot and the old core is back again.

I have tried deleting the core from the Retroarch menu and I have tried manually deleting the core from the libretro folder, either way it still reverts back. I have tried locking the new core, same thing happens.

Obviously there is something else I need to do to make the new core stick.

Does anyone know what?

Or perhaps direct me to the folder that is storing the old core that keeps getting rewritten?

I’m on an Arch based system too. The cores in “/usr/lib/libretro” are handled by your operating system. Any update of the system may override these, maybe that’s the issue? I personally changed this folder to “~/.config/retroarch/cores/”, so I have full control over it and can use the RetroArch internal update procedure. That also means, that these cores are no longer managed by pacman (note to other readers, pacman is the package manager of our OS). You can just move those cores into the “new” directory if you want or just initiate a download in RetroArch menu to get the newest version that is available there.

So, with that you can try again how it works out for you. I have locked cores that do not get updated and they should persist. I am not sure why a reboot on you system restores the old version, if you don’t update the system. That’s weird sounding to me and no idea what causes it. Maybe is something Batocera does? I use RetroArch directly from official Arch repos, but with folders set in my home/retroarch, so I have full control.

It’s definitely something Batocera is doing. I have just completely reset everything and am about to test your suggestion by creating a new folder specifically for the Snes9x core and then see if that persists through reboots. If I don’t follow up in 24 hours, I’ve jumped off a cliff.

You have to use the batocera-save-overlay command (via putty etc) after updating the core, See here:

1 Like

Thank you for that link. It will certainly do what I need but I have decided to stick with the pre-installed version in Batocera, because I have found that any game saves made with the new core don’t play correctly with the old (and vice versa). And to be honest, I didn’t notice any improvement by using the new core, I was just interested in trying. All this is new to me, especially Linux, and I am just fumbling my way around.

1 Like