[SOLVED][HELP] Missing Assets and Online Updater: nothing happen

Hi Guys,

this is the week-end about trying to make work properly RetroArch.

When the GUI is loaded a pop-up tells there are missing assets and to use the online updater; while it seems that the updater is actually downloading and extracting each of those files eventually those files aren’t in the $HOME/.config/downloads, and shaders and other stuff like logs are missing, at least based on the default directories.

At this point I am not really sure if those files are actually downloaded, maybe they are but not properly extracted because some permissions error, I don’t know since I cannot find any RetroArch logs.

Long-story short: a lot of stuff like shaders are missing, for instance /usr/share/libretro/shaders is missing, and using the online-updater is not working properly; it looks for instance that is downloading the shaders but those aren’t anywhere.

Some info:

[INFO] === Build =======================================
[INFO] CPU Model Name: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx  
[INFO] Capabilities:  MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX AVX2
[INFO] Built: Jul  4 2021
[INFO] Version: 1.9.6
[INFO] =================================================

and

 OS: openSUSE Tumbleweed x86_64 
 Kernel: 5.13.13-1-default 

Thanks!

The issue is that you’re trying to mix and match distro packages with stuff from the online updater.

The online updater doesn’t have permissions to write to /usr/share/whatever, so if that’s where your directories are pointing, it will silently fail. Many/most distro packages expect users to download everything from other distro packages, as well (retroarch-assets, [corename]-libretro for cores, etc.), and packaging systems typically aren’t allowed to write to locations in the user path, so they install them to /usr/share/whatever and point the config to those same locations.

If you want to use the online updater, you need to go to settings > directory and change those locations to ones that are user-writeable and then re-download your assets, shaders, etc.

2 Likes

@hunterk

Thank you very much for your suggestions. Those really made sense and actually remapping the folders worked out!

OpenSuse is not the distro I know the best, and I hadn’t known that they package software “as is” I am pretty sure on Debian default and permits would be done properly working.

Now I wonder if I had better to remapping all the folders on my home in order to have all the content manageable by the ‘updater’, so far I only remapped assets and filters… :thinking:

2 Likes