[solved] Issues with all three PS1 cores on Retroarch

Hi there! AS a new member I’m unable to open up a new topic, but I’m desperate.

I have been using Retroarch for PS1 games, however so far the pattern I’ve been suffering from is the Euro versions work fine, until a level or two later and then I just get stuck with this image:

This seems to only happen with the Euro ones as when I play the US releases it appears to be perfectly fine. Does anyone have any idea what the issue might be? I have all the different Bios needed and I am stumped…

Edit: Decided to add a bit more info to help. Both games are MediEvil. The first one I had to re-play the US version since the Eu version gave me the above error after I arrived at the Mausalium (3rd level I believe?) and with the second game it appears to be doing this on the second. Not certain why this could be and hopefully might give you a better idea of what I might be dealing with.

Current version of Retroarch 1.6.7 64x with many of the basic settings.


@DukeJP pointed out as a suggestion that skipping the intro was the portential cause for why it wasn’t working.

I know euro games sometimes had other copy protection, so that could be related.

extra protection? Heh, and back in the day almost everyone I knew had their chipped to play pirated games. Strange the EU version would get that extra treatment…but the problem I seem to be having happens mmid-game as opposed to when I load it up or right after the start screen. I get enough gametime to get sucked in before I get the error.

This is a normal issue with PAL copy protected games. Happens to me with Parasite Eve 2 PAL (Spanish). Just go to Redump.org and download the SBI Subchannels (Both medievils have them). Place that archive with SBI extension with your bin/cue files, RENAME THEM to the same name of your bin file. Example:

  • Parasite Eve II (S) (Disc 1).bin
  • Parasite Eve II (S) (Disc 1).cue
  • Parasite Eve II (S) (Disc 1).sbi

Technically, this is NOT a issue. This is the CORRECT way to emulate a console with a “pirate” CD. Your CD image lack this subchannel file, THAT is the problem, not Retroarch or the emulation :slight_smile:


Can you please add this as an issue to the libretro/docs github repo. Then we can add it as extra info to the cores.


Well I did what you said however it still doesn’t work. Now it won’t even load and claims that there’s a runtime error…Or did you mean I need to now turn it into a zip file?

It claims that the application had to terminate. I don’t really know why this is now happening now that I’ve added this .sbi file. All the files are also given the same name too so I’ve got no clue what might be going on…

I tried Medieveil PAL myself and boots ok here. My files are:

Maybe your files are wrong? Check your private messages.

hmm…strange the version I had, the (Track 2) was a .ape file instead of a .bin.

you need to convert .ape to proper format. guides should be available for that somewhere.

Now i understand. Its a bad, well, not bad, but incorrect ripped image cd. Use the Redump format for best results.

Ok I’ve done that and I looked up a way how to do it with ISOBuster and on the positive side seems there is a lot less issues graphically and can skip certain scenes, however it still brings up the same error…

thanks to DukeJP I found the issue was having the skip-intro enabled as since after I turned it off, the game continued to work as usual.

1 Like

Good! To clarify for anyone else: the problem was the option “skip bios” enabled. Skip the bios can give problems to some games (Saga Frontier i remember).

“skip bios” should really be not a configurable option as it just breaks stuff.

Hi, i have the same problem, i searched in retroarch options and i can’t find the skip bios option, where can i find it exactly so as to solve this problem?