[SOLVED] "Start core" option is gone?

I’m usnig the latest nightly of Retroarch on Linux and I can’t find the “Start core” option anymore ? This is problematic for me because for some reason I cannot start any Dreamcast game if Flycast is not started first. So, each time I want to play a DC game, I load Flycast, then start it, and then load the game. Now I cannot seem to be able to do it, so I cannot play any DC game anymore.

Have you checked if “settings->user interface->views->show load cores” is enabled?

yes ; I can load a core, I just cannot start it without a game, like I was able to before.

Currently i’m on a windows 7 machine. When i load content and select the flycast core everything works fine. Also scanning and starting the game from the playlist works. Also load core and then load content, current core is working. In a couple of hours i can test with my Linux Mint 19.1 laptop (libretro testing PPA)

EDIT: Also no problem on Linux.

Does it help if you enable Flycast’s “boot to BIOS” option? Since you can’t get to the core options before starting the core, you can enable it in the config file (retroarch-core-options.cfg). Find this:

reicast_boot_to_bios = "disabled"

And replace it with:

reicast_boot_to_bios = "enabled"

Unfortunately, it does not change anything.

Have you tried to load the game the normal way? (playlist or load content)

I tested Crazy Taxi (Europe) and on my side everything works fine.

Yes, it does not work.

So, I think I found the problem ; enabling run_ahead is what causes Flycast to crash ; disabling it fixes the problem. There might be something that changed recently in RA or Flycast because I used to have run_ahead enabled globally and when I launched Flycast, I had the message “Run_ahead is not supported by this core, disabling…” and the core launched fine without Run_ahead.

1 Like