some controllers work in games but not in mapping

hi everyone, i have some controllers that are not recognized when trying to map them. they work fine in games and menus if i have a autoconfig file for them (or if i manually edit retroarch.cfg), but when i click on the button i want to map (when it prompts you to press the button you want to map) it doesn’t recognize any of the buttons. it does recognize my keyboard and mouse and my arcade sticks but others don’t seem to work, it happens on wired and wireless controllers. i tried changing the drivers types, uninstalling - reinstalling, reconnecting, even tried a new install of retroarch, it still happens. but it happens only on retroarch and only on the mapping screen, this one: Untitled

it’s not a big deal, it’s just means i need to manually create my autoconfig files but i really like to know what is this problem. any help will be appreciated

Hello Mr. haimbilia. Controller configuration is relly a problem in RetroArch. I’ll study and learn how to solve yours, and my problem with 2 different controllers as P1, or P1 and P2.

Solve this issue without erase all RertoArch folder. What a mess. There must be a simple solution.