Sound stutter possible to fix?

I have had issues with the sound in retroarch now for many years. And, well I have had other things to fix so i guess its time now. Whenever I play ps1 or n64 games the sound clicks or disappears for maybe half a second every now and then. I have seen other topics on this so I am not sure if it is fixable. I have tried every sound setting there is, including other driver (wasapi etc). If i turn on/off v sync wont matter. Like I said its been for this for years on both my two latest pc’s. I dont want to use another emu but its sadly the only thing left for me :slight_smile: have had issues with the sound in retroarch now for many years. And, well I have had other things to fix so i guess its time now. Whenever I play ps1 or n64 games the sound clicks or disappears for maybe half a second every now and then. I have seen other topics on this so I am not sure if it is fixable. I have tried every sound setting there is, including other driver (wasapi etc). If i turn on/off v sync wont matter. Like I said its been for this for years on both my two latest pc’s. I dont want to use another emu but its sadly the only thing left for me :frowning:

☆Edit maybe wasapi exclusive mode fixed it. But is that really something you gotta use to fix sound stutter?

I think I have figured out how to fix this issue in case anyone else has it. I have to set Retroarch with higher priority in the task manager. I have it at high. So far it works great without any sound issues. It is also possible to make it run like that constantly without needing to change it whenever you start Retroarch. Just add this in the target box to a Retroarch shortcut. In this example we have Retroarch on C:
C:\Windows\System32\cmd.exe /c start “” /High “C:\Retroarch”

1 Like

Ok. It didnt help. The sound lag is back. I have done anything possible now*. It comes and goes. For example now it is in Metal Slug, but game and core doesnt matter. Is this really not fixable?

*I will try wasapi with high priority, its a combo I have not tried.

I sure don’t have it, so it’s not something that’s unavoidable/unfixable, but there are many different things that can cause it both inside and outside of RetroArch, so it’s a tough thing to troubleshoot (hence my silence on it so far).

Common things to check are power consumption profiles (make sure you’re set to ‘max performance’) and vsync/audio sync issues.

Sorry if I sound unfriendly in this thread. Its just soo annoying. I MIGHT have found a solution. I changed in nvidia cntrl panel, tripple buffer to on and multithread to on. I dont know if either one actualy does a difference but it has worked so far. Power savings in windows are all set to max performance.

1 Like

It might help if you posted what CPU/GPU you are using and which cores (and plugins in case of the N64) exactly.

Sound issues like this are usually tied to emulation not being at 100% speed.

Also, make sure you turn Hard CPU sync and run ahead to OFF if performance is slow. Threaded video ON might also help in some cases.

It is on every core. But maybe it has stopped now since what I described what I did in the Nvidia panel. Threaded video in Retroarch on/off made no difference. I will have to try another day because sometimes it appears again after a while. My cpu is a i7 8700k and my gpu is a gtx 1080Ti.

Do you use the HDMI from the GPU for your sound?

Maybe the 1080 is idling.

Setting max performance in power saving options only applies for the CPU i think. If that didn’t work you could add RetroArch in the programs in your NVIDIA driver profiles and set the GPU to max performance there. But only for RetroArch because otherwise it will use more power in Windows as well and you don’t need that.

Hmmm, I use my blutooth headphones for sound.But as I play in 240p, its not wierd if the gpu is half asleep I guess :slight_smile: Sadly, I sat it to performance mode in Nvidia a long time ago so its not that either. I havent had time to play so much yet but so far it is better. But I want to play a few more hours before I say its gone.

Started again now, so damn annoying!

Maybe something is wrong with the bluetooth thingy. I never had a good experience with those. Its a crapshoot.

Maybe it is that. I dont think I have had issues with it in other games or stuff. But maybe it wont just work with Retroarch. It is much better and less often now after I changed that in Nvidia but it still happens. Its just wierd now I think.

Changing the gpu to max power instead of max performance in Nvidia might have removed all sound stutter. But again, I need to play a couple of hours to confirm that it actually works now.