Swapping between Windows 10 and Xbox Series X|S

After setting up my build, I haven’t ever felt a strong pull to try RetroArch on any other supported system. I mean, I built a whole dedicated console for it out of my Windows PC, why bother? Well, I’m about as in love with my X|S as I can be before things ‘get weird’ (haha) so when I was reminded about the whole ‘dev mode’ thing I got pretty excited.

Currently my ENTIRE setup is housed in a 4TB ext HDD:

  • RetroArch
  • BIOS
  • Games
  • Save SRM
  • SaveStates

I know I will have to setup a separate instance of RetroArch on the X|S itself, obviously, but what I am wondering is if it will be possible to configure the X|S version of RA to use my existing directories for saves, games, BIOS, etc.

Ideally I want to be able to just take my hard-drive with me around the house, and not have the X|S and my PC(s) running entirely separate from one another.

Assuming it’s nearly (if not entirely) identical to the Xbox One setup - I’m hoping someone can fill me in a little bit before I decide to buy this dev license.

that’s a good question. I’m not sure how much access it has to external storage. If full access, just change your directories and you should be good.

1 Like

lol well now ya done it hunterk. Now I gotta test it hahaha.


1 Like


Ok, so I ‘finally’ got RetroArch on the thing. It does allow me to change directory settings to E:\Memory Card\Saves and E:\Memory Card\SaveStates, for example. However, when you restart the app you get a weird error:

Path "" is not currently accessible. Please open any containing directory to access it.

Can either cancel, which makes the error flash 3 times in a row - and then RA opens and the directory is set back to default. Or, you can hit “Open File Explorer” but it doesn’t state if you are looking for Save path or SaveState path, etc. Plus, if you take too long picking the app “fails to start” haha.

So unfortunately it’s not quite as drop-in as I was hoping once it was setup. Oh well. At least we know now I suppose.

I am having trouble with assets though. I used the online updater to download assets - and while the font in XMB switched, no images came up. Restarted a few times, switched to Ozone, downloaded twice more… no asset images are displaying in the menus. Very strange. Not a big deal I guess.

Managed to boot up Sonic 3 Complete just fine so, I just need to figure out how to get the BIOS files in place and I think I should be set… though I don’t know how much I’ll use this version without access to my ongoing saves

I thought I could use OneDrive as a secondary, but apparently Xbox gutted that functionality out of the internal File Explorer. :frowning:


Hey man, I had the exact same issue when I loaded Retroarch on my Series X yesterday. The graphical assets never load, no matter how many times I tried or restarted it. I had to switch to Ozone to be able to navigate around the menu or you can’t see the toggles or anything.

I tested shaders and was hoping CRT Royale would work but no dice, it’s all distorted. Perhaps its not compatible with d3d11/12? Crt-easymode and lottes worked though.

1 Like

Works on d3d11 on my PC, at least. d3d12 looks funky, though. Is this how it looks on your end?

This is how it looks on my end. This was using d3d11.

The game is Dodonpachi via FBNeo.

It looks like there may be some other stuff going on, but does it help if you change the ‘mask - sample mode’ parameter from 0.0 to 1.0?

Let me know if you figure this out!!

1 Like

I switched the video driver to D3D12 and the image assets loaded.

1 Like