Switch PCSX-ReARMed crash when BIOS file is in present

Hello everybody!

I’m new on libretro on Switch and i’m facing a problem with the pcsx rearmed emulator on a switch. Retroarch is 1.9.0 - installed on 32 Gb fat32 SD card

If i put a bios BIN file in /retroarch/cores/system it get correctly detected by the core (in core information) but the system crash when i start a game with message “The software was closed because an error occurred.”

Tried to log error but nothing appears strange in there: please check:

Latest message is “[libretro INFO] CD-ROM EXE Name: SCUS_949.00;1” then it crashes.

tried with different bios files, tried different core vesions withous success.

Does anybody else faced this? what am i missing?

This looked related to my case but links are dead:

Regards - JS

Do other games work? Did any games ever work? Have you changed any core options from their default values?

Thanks for your time. It works WITHOUT any bios put in core/system with a warning message. No options changed at all - all default. It crashes with all PSX games, no matter the format of the file.

Its a brand new setup.

I have tried with or without bios and it crashes with any of the game I try. I don’t really know what to do anymore ? Anyone knows where I could find older versions of this core ? Couldn’t create a new post so I’m writing here.

As it doesnt looks to be the exact same problem as me, i’d suggest you to open a new thread when you can do so. This to avoid mixing and allow relatively clear threads :slight_smile:

Same problem here, even with the currently nightly version happened. I tried the same as you, hopefully someone find a solution soon. :confused:

1 Like

Okay I got a solution and it’s hilarious, just don’t put any bios and the game work. I don’t know what’s wrong here but I won’t even bother.

This not a solution for 3 reasons: 1: It was not stated in op and it should have, but we already know it works without BIOS. (my 2nd answer) 2: Some games does not works or work as they could 3: It should work.

I asked in the RetroNX discord server and they asked for an atmosphere crash log and if you could try with BIOS but audio driver set to switch thread

Hello, up ! same problem for me. I tried to load bios without success.

Actually emulated HLE bios works but i wonder if there is a way also to get a bios that allow PCXRearmed to use bigger screen resolution. Second problem, emulation is very slow for psx games on switch, like quake 2 or other are laggy. Do you experience same problem ? What option do you use ?

Thanks for your help: Tried with BIOS with switch_thread audion: same crash. How can i provide an atmosphere crash log? i got some files in micro SD\atmosphere\fatal_reports but they dont looks very usefull to me :slight_smile:

Regards

You can force resolution in the core settings and you may want to try overclocking to get a performance boost.

Thank you for your reply. I will try to look better in the core option where to force resolution cause i really cant find it. This is weird. I use HLE bios since i cant load official bios in retroarch switch version.

Second thing, it s already very slow with original resolution, so i guess double it will make it worst. Overcloaking doesnt make any siginificant improvement.

But what really make me think it’s something else, its the fact that when i use PPSSPP with bigger resolution i experience slow, same with nintendo Desmume or Melon emulation.

BUT, when i play PSP games in the original PPSSPP app made for Switch via HB App Store, it s very fluid, no lag at all. I can double (maybe triple) the resolution easy and the Nintendo Switch emulate perfectly and smoothly

I use gl video driver in the retroarch option. It’s seems to be the same driver for the PPSSPP app on HB App store.

It’s sad cause at the end I cant enhence or even play normaly due to lagging on Nintendo DS, PSP, PSX via retroarch cores.

I guess i mess something if for you it works without lagging ?

I just wanted to say I am experiencing the same problem since I updated the core about a week or 2 ago. Until then it worked fine. Luckily my paranoia made me backed up my cores regularly. :grin: If I take the core from 13 october it works fine.

Do you mind sharing it somewhere?

Sure, this worked for me: https://multiup.org/en/mirror/9effcc023f23bff10b33ba36cba00e7d/pcsx_rearmed_libretro_libnx.nro or https://multiup.org/9effcc023f23bff10b33ba36cba00e7d

You’re the man! It works perfectly now! Many thanks!

1 Like

No Problem, glad I could help out. :+1: Hopefully this will be fixed in the newest core.