switch res problem with master system games


#1

Hi everyone! I have a trouble with master system games. I use genesis plus gx and when i load a rom, games start out of sync…it would seem that retroarch didn’t find the correct resolution All other emulator work perfecly even megadrive rom i use win 10 ,crt emudriver with super resolution and radeon r9280 with right resolution installed (2560x192 50 and 60hz). If i try to set desktop resolution in 2560x192 before launch retroarch, master system games run perfecly. How can it be? thanks for yours answers.


#2

I believe most GPUs can’t output less than 200 vertical lines of resolution, so systems with less than that are padded to 200. If you add those same modelines but with x200, does it treat you any differently?


#3

If accurate border emulation is activated, that requires more lines than 192. Some games by Codemasters also make regular use of 224 line mode outside of border effects I believe.


#4

ok, thanks for the fast replies. I will try to install the 2560x200 and see if it works.

I don’t understand why if I set the desktop resolution to 2560x192 and then start retroarch works fine. onscreen overlays say 2560x192…


#5

RetroArch will work with whatever res your desktop is set to, it doesn’t care. Where the issue comes up is the switchres stuff, which expects very specific modelines to exist so that it can switch to them.


#6

I didn’t express myself well, sorry.

Retroarch and various emulators work very well and switchres too, the problem is that it doesn’t seem to find the 2560x192 with which the master system works. When I try to load a master system rom it goes out of sync. I think my video card (radeon r9280) supports the 2560x 192 because I can change it from my desktop. there’s no problem if I set the 192 and then launch retroarch, the ms games run perfectly at that resolution.


#7

Right, it just depends on what the core is asking for, which, as I mentioned, may not be the 192 you expect. Which core are you using? Do you have the borders enabled?


#8

I tried with genesis plus gx and picodrive, same problem for both. No borders enabled. Do you think ms uses other resolutions besides 192?


#9

While 192 is the active resolution, I think it uses 240 with borders (like pretty much everything else). The NTSC standard is 480i, so if it’s NTSC-compliant, it has to be some variation of that.


#10

I had to manually turn on borders in core options. Switch Res wouldn’t do it for me on it’s own. The problem with this is it turns it on for genesis games too, so you’ll probably want the split SMS core for this feature.


#11

Ok,tomorrow i’ll try to install other resolution (like 2560x200) and launch gx plus with borders enabled. Thank you all.


#12

Enable just the vertical borders. That way it will run SMS at 192 and Megadrive at 224 with appropriate padding for each.