System folder location (and others ?) not recognized

Hi there,

I updated two days ago my retroarch installation with the latest nightly.

Everything worked fine beside that, I don’t remember my previous version number, but it was updated at the beginning of the year I believe.

Right now, my installation is a bit messed up. It seems that Retroarch doesn’t recognize anymore the default system folder and where it’s located.

Except for roms, all the folders used by Retroarch are the default ones. Retroarch finds my roms without problems, it also finds the assets, thumbnails, almost everything I’d say, but it doesn’t seem to recognize the System folder for whatever reason.

When I try to start a game from my playlists, a new folder for the core is created at the root of the disk where Retroarch is installed.

Details:

My retroarch installation folder is the following one: G:={ Emulators[X] RetroArch

Here is the one for my Playstation ISOS for example: G:={ Emulators[PS] Playstation

And here’s the default System folder I always used before: G:={ Emulators[X] RetroArch\system

Now, for example, if I want to play Donkey Kong Country (SNES) with Bsnes-Mercury core, it creates a folder here: G:\bsnes-mercury (DKC.srm being created here)

My retroarch gamepad remaps are not functional for each cores either apparently, but I can navigate the menus like before without problems.

What happened and how to fix this ? It’s weird because it doesn’t seem to affect all the default folders, just the system one, and perhaps a few others, I’m not too sure.

EDIT: Seems the backslash doesn’t appear everywhere in my folders paths here, probably due to html I guess, hope it’s clear though.

EDIT2: Also: yes, all my folders appears correctly located when I check the desktop configuration, all have the same custom path that used to work before the update.

Ok so after a few checks, it seems I kinda messed things up in my explanation after the panic attack encountering this problem.

I cannot edit my original post, so if a mod wants to do it / can do it, the title should be changed.

It’s not the “System” folder that is not recognized, but the “Saves” ones.

I managed to fix the remaps not working - no problem at all actually, it’s just that for some reason, a controller (plugged) that I’m not using was acting as Input Entry #1 in Retroarch. My mistake here.

What remains is the Saves folder being recreated for each core / each game I’m playing at the root of the disk where Retroarch is installed.

I tried different things today to pinpoint the problem, but I’m running out of ideas.

Did you try:

Settings -> Saving

In that menu you can set how RA will sort saves and save states.

Also :

Settings -> Directories

To set default directories.

Thank you for the hints and ideas.

I didn’t check the Saving configurations earlier, but everything seems okay to me right now, no funny option or anything really different from my previous configuration apparently.

All directories are correctly setup including the “Saves” ones in the directories options too. This didn’t change too from my previous configuration (that’s where I don’t understand the problem at all :confused: ).