The quest for 240p/480i on my CRT TV

This isn’t simple, and that’s fine, but I’m so far past the point of trying to figure this out. I just need help getting this to work.

What I have: Consumer 240p + 480i/480p CRT with Component input. Windows 10 PC w/ Display port, DVI-A, and VGA.

The PC side of things is extremely flexible. I can change out my video card, I have several. I can use my other PC - I don’t so much care.

The TV is not flexible at all. No RGB modding. No SCART.

I got this HDMI to Component converter for Christmas. (Not a scaler - this converter was recommended on several old reddit threads for this exact purpose)

It’s rated to accept 480i/p all the way up to 1080i/p and output the identical resolution. I confirmed this with the included documentation as well.

On the software side I’m creating resolutions using CRU - Custom Resolution Utility. On the PC in question I am open to using CRTEmuDriver.

Summary: RetroArch + Win10 > DVI-A adapted to HDMI > Converter > Component > TV.

I can get 1920x240 @ 60Hz to work. I cannot get any other resolution, like 1920x480 @ 60hz to work.

What am I doing wrong? What do I need to change?

I just want 240/480 on this CRT tv.

What am I missing? What should I fix?

Ok so, With my current setup I’ve installed CRTEmuDriver on an ATI Radeon HD 5000 card. I’m getting farther but it’s still broken.

I followed the guide here:

So I’m pushing those exact resolutions through the NTSC preset in VMmaker. Except they aren’t displaying correctly.

640x480 is… Jittery, for lack of a better term. Nothing is in focus. All super resolutions are sharp af, but the whole screen is scrolling upwards infinitely repeating itself.

I don’t know how to stabilize these resolutions.

The good news is RetroArch seems to be calling on proper resolutions… I say seems because it’s hard to tell with everything scrolling.

rolling usually means there’s a sync problem with your modelines.

What model TV is it, exactly?

1 Like

I’ve been playing with ArcadeOSD, not that I understand what I’m doing in these settings lol. I’ve found I can speed up or slow down the roll, even reverse the direction, but I can’t get it to stop.

Model is a Phillips 27PS55 S321.

I have the original remote and can enter service menu, in case that matters for this. Not sure.

The DVI-A is properly converted to HDMI rather than (passivley) adapted, right?

Been switching back and forth a bit, but making progress in itty-bitty little steps.

I gave up on the Radeon HD 5000 and went back to using an R5 240, did the CRTEmuDriver install on it - all worked great there. I am pushing that out of the DVI port. The DVI port is just a simple physical (passive?) adapter. (not powered). From that adapter to HDMI to the Portta HDMI to Component Converter.

Now, I am no longer getting the crazy vertical scrolling on resolutions. I’ve found installing the modelines via VMMaker doesn’t always work right the first time. Took a couple tries of just installing until they were no longer scrolling.

All 240p-esque resolutions are now perfect. Any imperfections are to be sorted with TV’s geometry and/or “Image-Adjustment” shaders.

The interlaced resolutions though, are now the only thing left giving me grief. Any 480i-esque resolutions are not working correctly. They are displaying with scanlines and very juttery. I can make it a bit less frantic by switching the ‘vertical sync pulse’ from 6 to 8 in ArcadeOSD but it’s seriously like an “interlaced 240p” for lack of a better description.

I have my real Sega Genesis connected to the other AV-input to do comparison, and 480i looks properly interlaced on Sonic 2’s 2-player mode. I can’t see the scanline effect at all. I would believe it’s progressive if I didn’t know better.

Switching back to Sonic 2 via Gens core though, (and, again, in Arcade OSD on all 480i-esque resolutions) I can clearly see the scanline effect while the active lines flicker on top of each-other instead of in the alternating spaces.

I hope I’m making sense…

Having some quirks with resolution calling too. 1920x192 works great in ArcadeOSD - but Master System games aren’t calling it properly from RetroArch. It stays on my 640x480i desktop mode.

Gens core for that one. Works on Genesis 224 and 448 resolutions (problems with 448i resolution in general, not withstanding)

Check the border settings I guess. And I don’t think your DVI output is analog.

So it looks like the problem is the converter itself. Despite seeing it recommended in several places I’ve spoken to a user who states he had this exact same problem with interlacing. The DVI port is most def analog, so I’m going to order a different adapter that he recommended and follow up on that end of things.

I’m guessing the recommendations for this came from folks who never attempted interlaced resolutions. I mean, it works perfectly with the progressive ones so I can imagine people just playing NES or something and thinking they hit the jackpot.

More on the actual RetroArch side of things though, I can’t figure out why I can’t get RetroArch to pull up 1920x192 when loading Master System games. The resolution itself runs wonderfully via Arcade OSD and within RetroArch itself. Once I have an SMS game open, I can go into Settings>Video>Output and change the resolution to 1920x192 and it looks wonderful - for some reason it won’t do it automatically though.

I know there are borders you can add to the top and bottom in core options, but that of course changes that setting to be ‘on’ for Genesis games as well - which isn’t ideal. I don’t think there is a method for saving core-options per content directory, is there?

The DVI port is analog only, and it’s connected to HDMI (which is digital). This doesn’t require some sort of active converter?

From everything I’ve read HDMI is capable of pushing analog signals, it’s just not something that’s ever used outside fringe cases like this one. Even CRTEmuDrivers documentation references it. Either way the adapter/converter/transcoder that was recommended to me is VGA to Component, so I’m going to just go DVI>VGA>Component with that setup and bypass HDMI all together.

Luckily the current one will let me enjoy the vast majority of my collection this way. Dreamcast and some varying titles though will have to wait, unless I want to play them in 240p. Sonic Adventure looks terrible in 240p lol. (OOOOO though I can try running Street Fighter 3!)

I just hope I can figure out Master System while I wait for the new adapter.

If you’re using RetroArch’s switchres to automatically change res, I think anything less than 200 is padded to 200, since that’s the lowest that most GPUs will put out.

1 Like

That worked like a charm! Thanks hunterk!

1 Like

Alright so my adapter finally arrived!

Device was from an eBay seller named Linuxbot3000, shipped out of New Zealand. Nicely assembled little device. Best of all it works absolutely wonderful. Everything I send to it seems to ‘just work’ compared to all these other weird adapter solutions I’ve tried. Highly Recommended to say the least.

I’ve got nearly every resolution I can think of working with NTSC and PAL games now… except MS-DOS.

I can install 1920x200 @ 60hz - no problem but when launching games via DosBox-Pure, the initial menu registers at 640x400 with 0Hz. I’m not sure what to make of that… but then it gets weirder.

I tried to install 1920x400 @ 60hz, 55hz, 50hz, and even 70hz, and every time VMMaker sees this as a “redundant resolution” and refuses to install them.

I assume 640x400 is just the interlaced brother to 1920x200 - so I don’t know what I should be doing to make this work.