Thumbnails download in desktop mode, but not in RetroArch?

Ran into the issue recently. Not sure if something got switched around in my settings. I made sure the name/spacing of the game title was in line with the libretro thumbnail database.

I’m able to download the thumbnails through the desktop mode but not in the RetroArch app.

Any help is appreciated. thx

I just tried both modes and they work fine.

I recommend you to update RetroArch and let us know if it fixes, it may be a bug fixed. And the correct names are very important, but if it works in desktop mode, it is because they are ok. Anyway it is always advisable to use the No-Intro and Redump set names.

1 Like

thx for the response. i made a fresh install of RetroArch and still same issue.

When I did a fresh install I transferred over config, system, thumbnail, playlist and saves folder over to new install from the existing RetroArch i had before. Could tht be causing the issue?

I don’t think so, the only file that can affect is retroarch.cfg, it is general configuration that is in the root.

How are you updating the thumbnails?
You can try, in the Playlists, selecting a game you have the option “Download Thumbnails”, to download the thumbnails of a single game. Or in “Main Menu - Online Updater” you can download the thumbnails of the complete Playlists.

These are the ways to update the thumbnails from the RetroArch interface. If it doesn’t work, I recommend you to generate a LOG this way and share the result, so you can review it here, in the forum.

1 Like

I’m going to the individual game that I’ve renamed to match the database and clicking download thumbnail.

I will get the log now. Are there special instructions on how to post the log?

Did it work?
I insist, if the thumbnail download works for you in desktop mode, it should work in the normal interface, you can delete the retroarch.cfg file momentarily to see if it works.

Paste it here, if you want you can use the ‘hide details’ option so that it does not take up too much space.

1 Like

hahaa when you mentioned this in the last post I deleted it and tried to go in and fetch the thumbnail with a fresh config file, but no luck.

[INFO] RetroArch 1.16.0 (Git 06deba2) [INFO] === Build ======================================= [INFO] CPU Model Name: Intel(R) Core(TM) i5-8300H CPU @ 2.30GHz [INFO] Capabilities: MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE42 AES AVX AVX2 [INFO] Version: 1.16.0 [INFO] Git: 06deba2 [INFO] Built: Jan 4 2024 [INFO] ================================================= [INFO] [Input]: Found input driver: "dinput". [INFO] [Environ]: SET_PIXEL_FORMAT: RGB565. [INFO] [Core]: Version of libretro API: 1, Compiled against API: 1 [INFO] [Core]: Geometry: 320x240, Aspect: 1.333, FPS: 60.00, Sample rate: 48000.00 Hz. [INFO] [Audio]: Set audio input rate to: 48000.00 Hz. [INFO] [Video]: Set video size to: fullscreen. [INFO] [Vulkan]: Vulkan dynamic library loaded. [INFO] [Vulkan]: Found vulkan context: "vk_w". [INFO] [Vulkan]: Detecting screen resolution: 1920x1080. [INFO] [Vulkan]: Found GPU at index 0: "NVIDIA GeForce GTX 1050 Ti". [INFO] [Vulkan]: Found GPU at index 1: "Intel(R) UHD Graphics 630". [INFO] [Vulkan]: Using GPU index 0. [INFO] [Vulkan]: Using GPU: "NVIDIA GeForce GTX 1050 Ti". [INFO] [Vulkan]: Queue family 0 supports 16 sub-queues. [INFO] [Vulkan]: Got 3 swapchain images. [INFO] [Vulkan]: Using resolution 1920x1080. [INFO] [Vulkan]: Using RGB565 format. [INFO] [Vulkan]: Loading stock shader. [INFO] [XInput]: Found XInput v1.4. [INFO] [Joypad]: Found joypad driver: "dinput". [INFO] [Video]: Found display server: "win32". [INFO] [WASAPI]: Client initialized (shared, PCM, 48000Hz, 64.0ms). [INFO] [Audio]: Started synchronous audio driver. [INFO] [Microphone]: Initialized microphone driver. [INFO] [Display]: Found display driver: "vulkan". [INFO] [MIDI]: Output device: "Microsoft GS Wavetable Synth". [INFO] [Playlist]: Loading history file: "C:\RetroArch-Win64\". [INFO] [Playlist]: Loading history file: "C:\RetroArch-Win64\". [INFO] [Playlist]: Loading history file: "C:\RetroArch-Win64\". [INFO] [Playlist]: Loading history file: "C:\RetroArch-Win64\". [INFO] [Playlist]: Loading favorites file: "C:\RetroArch-Win64\". [INFO] [Config]: Saved new config to "C:\RetroArch-Win64\retroarch.cfg". [INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds. [INFO] [Core]: Unloading core.. [INFO] [Core]: Unloading core symbols.. [INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

Lmk if that’s too hard to read and I can try to make it easier to look at.

In the past, on the bottom left it would load the set of 3 thumbnails that you’re familiar with when downloading thumbnails.

Don’t worry, it looks good.

When you generated that log, did you try to download the thumbnail?

Wait a minute…

That’s an Arcade game.

What core are you using? How are you generating the list?

1 Like

Yes. Opened RetroArch, tried to download thumbnail, closed the app, copied the log. Also included a picture of the app not being able to fetch the thumbnail as well.

FBNeo. It’s a Neo Geo game but I’ve tried to download a thumbnail on SNES, for example, and I’m still having the same issue. I thought maybe a setting was off or something but I really have no idea at this point.

I really appreciate all your help bro

I have tried downloading thumbnails from FBNeo and they work correctly.

In the first message you said you changed the name, I have a feeling this is the problem.

Why did you change the name and how did you generate the playlist?

To create playlist of any Arcade core, you need the updated romset of the specific core, the .dat with the roms information and to do a manual scan. In the documentation you have a step by step.

The Snes case is a mystery to me.
Did you also change the name?

By the way, the image you share, says it downloaded and extracted fine.

If you generated the list well and you can update the thumbnails from the Desktop, I think the best thing to do is to create a report in github with the generated Log, it may be a major error.

1 Like