UAE core for Retroarch

I tried puae without success today. Is there a good amiga core which can be used to play turrican, north and south, cannon fodder? There are so many classic amiga games which is why i am a little bit surprised that no stable core exists.

1 Like

I dont believe there is anything more stable in retroarch than PUAE…its not a good core by anymeans. The other cores uea4arm for lakka and fsuae never got finished.

Try this guide for getting the config files setup… its as good as it gets for info on this core afaik

1 Like

I tried it. but i am still going to the main menu. The game does not start.

If I get s chance this week I will dig out my pure setup and try it out on android.

Will let you know.

It seems the core does not find the game. I already searched for a documentation how to setup puae on windows. I guess the issue is the path. Puae uses relative pathes instead of absolute. But my games are on a different partition. So I think the path points to a non existent place.

Same here, I can’t manage to load an uae file with UAE core on RetroArch 1.7.2 under Win7 x64. I have RickDangerous.adf file, RickDangerous.uae file, kick.rom (e40a5dfb3d017ba8779faba30cbd1c8e) Nobody there for helping with this core ?

This core is not a fan favourite and with better options outside of Retroarch it just doesn’t get a look in.

If mouse input was fixed it would be a lot better.

I was also trying RickD last night with no luck

If I put my uae file content in a .uaerc file (at RetroArch root folder), then it almost works (I can see Rick Dangerous loading screen, but the game doesn’t start). So, it sounds like uae file is not read at all by the core ! Strange, because on this link, it seeems to be working. Maybe the core doesn’t work on Windows

1 Like

Thats odd, i did see reference in the log to uaerc but wasnt sure.

Iirc it was looking for kick.rom and stuff in ./././.uaerc which was above my head.

I will have a lool tonight

This is exactly the issue I have. It seems the core does not detect the files/paths properly.

@papermanzero @tom5151

I have just booted Rick Dangerous.adf but its 11pm and going to bed on a win is best :slight_smile:

I dont think this is the correct way to do it but its a step forward from tom5151’s post above.

.uaerc file in your RetroArch folder along with your ADF file kick.rom in the system folder

kickrom_path = ./././system/kick.rom floppy0=./././Rick Dangerous.adf

Here is my notes


Well, that confirms that the core has issues with pathes :smiley:

RetroArch 1.7.3 doesn’t change anything. UAE core still doesn’t work on Windows :disappointed_relieved:

1 Like

Any update about the Amiga status in RetroArch? Is it usable in any core?

I’m playing amiga on my Shield TV and Moto Z2 Force. I’m using and old version of the core, whdload, modified whd files by me and a .uae per game. It was an insane work, but I can play.

I’ve used this tutorial:

And it works. Is a HELL OF WORK, but works.

I want to know if puae is working for windows. An amiga core would be great

I’m wondering if I should start a bounty source to port fs UAE to libretro.


You mean like this:

Works great, except for this (probably affects other games as well haven’t tested much):

Development seems to have stalled, no new commits and no re-sync with upstream fsuae.

1 Like

Oh so some work has already been done. Maybe a bountysource to enable WHDLoad and upstream then as incentive.

Sure, I’ll pitch in. There hasn’t been a lot of activity on FS-UAE itself these days but it’s still in a much better state than the alternatives. The amiga deserves some love :slight_smile: