Updated Dolphin core always crashes


#1

Wished there was a generic sticky thread for reporting core crashes.

It worked fine before I updated,was hoping for improvements but instead lost access to a functional core.

Tried opening Simpsons Hit & Run and Zelda Wind Waker but the app crashes out with the typical “has closed” error. Though the game I had working on it before that I tested was Twilight Princess (Gamecube) but I expect the same result once I check it as well.

My Shield TV is still on OTA 6.3/Android Nougat and I also tried the most recent nightly Aarch64 version of RA after setting it up and grabbing the core again. (I installed 64-bit on top of my 32-bit version before the unique app ID was added to it)


#2

Make sure you have Run Ahead and Rewind disabled. These features are not supported by the Dolphin core and can cause it to crash.

It would be helpful to examine the log to find the cause of the crash.


#3

Sorry for the late reply.

Both run ahead and rewind are off for the core,as it ran before updating the core.

I set log settings but I couldn’t find a log file after testing the crash and browsing all of RetroArch’s accessible folders in Android/Data/ and its primary folder. (shouldn’t lock away any folders in root restriction directories,IMHO)

I don’t know how to get a log file from RetroArch because it doesn’t seem to generate one even when changing the log type and I don’t know the best logcat app to choose from because I can’t find the one that used to be good. Android versions changed to make things harder since the logcat apps I tried recently for something else didn’t get a single thing from a specific app. Because of these issues,using external logcat apps is a pain,so it would be nice to have RetroArch itself actually generate a log file in one of its readily accessible folders to make things way easier.