Various Isssues with Retroarch

Retroarch = Latest Nightly.
OS = Win10 Home - 19041.685 latest updates.
Graphics = 2047MB NVIDIA GeForce GTX 1060 (MSI).
RAM = 16GB.

I have a few problems with RA.

  1. The first is that the controller has stopped working for Playstation 1 + 2 games, though I’m unsure when this originated. I first noticed it about two weeks ago with the Nov172020 nightly build.

  2. When I now check for nightly updates, I get a 404 error popup in RA’s desktop window. I use the Desktop window’s, Tools/Online Updater/Update Retroarch (nightly) option. I noticed in the Settings that the URL is:

But the actual URL for the nightly releases seems to be this:

So I tried removing the “latest/” part of the URL in the settings, but this did not work. Just noticed the “https” so attempted another update after changing the URL, with and without “latest/”, still not working.

  1. Checking for new cores with the Settings/Network/Updater/Show experimental cores option ticked, doesn’t show the new Dolphin core. I’ve downloaded the new Dolphin-data folder which is placed in the “system” directory, but when I use the Download new cores option, Dolphin or any new cores aren’t displayed. I do have an old version of Dolphin core which I have deleted in favour of the new one, but that made no difference either. OpenLara also does not appear in this list of cores.

  2. Citra core keeps crashing. It used to work, but again, I am not sure when this started, but it now crashes with every launch of a game. Issue found around two weeks ago.

Please help…

I don’t know about PS2 games, but if you’re using PCSX-ReARMed core, try setting the multitap option to “disabled” instead of “auto”. Other than that, you can try to delete any core remaps you might have and/or delete the core options files that might be causing issues.

#2 is known and is part of our server migration. It should hopefully be fixed soon.

#3 is also part of the server migration. In the meantime, you can get dolphin builds from

#4 if you pastebin a log, I can take a look. Dunno why it would have spontaneously broken a couple of weeks ago. AFAIK, nothing has changed about the core or the frontend since then that would cause that :man_shrugging:

The last Citra core from the buildbot crashed for me as well. I had to download a different build from another source (which works but crashes on exit). The core has been removed from the buildbot since a few days ago as well.

Thanks for your reply.

  1. How do I go about changing this setting, I can’t find it! :upside_down_face:

  2. Great news, thanks.

  3. Updated but still not working. I have downloaded the Dolphin-data package to System folder too. But I now have two Dolphin folders. One from the previous core and one for the updated core. Which is correct?

RetroArch\APP\system\Dolphin - Updated core.
RetroArch\APP\system\dolphin-emu - Old core.

(btw, I have moved the config files through RetroArch to an APP folder for my own ease of use.) What is the exact path I should be using under the System folder?

  1. I don’t think it happened a couple of weeks ago, it’s just that was when I noticed it. Personally, I’m not much of a gamer anymore. It’s mainly for my kids. :wink:

Great app btw!

That Dolphin folder gets created in the “saves” folder for me. I don’t have anything Dolphin related in my “system” folder.

I am having an issue. I have been using RetroArch for my emulator of choice with LaunchBox. Mainly because I’ve been finding it easier to use simply RetroArch instead of multiple different emulators. I am moving all of my emulation over there one by one, ensuring that everything works correctly with the core, and that the settings are the way that I like them.

Now I have gotten to PPSSPP and Dolphin. I cannot find those cores anywhere. Looking around the web and at tutorials, its always “just there.” It isn’t with me. I looked further and someone stated that it will only work with a 64 bit version. I have no idea if the one I am using is 64 bits or not, so I said screw it and redownloaded the 64 version (1.9.0). Still no PSP core. So I downloaded the Nightly Version (64 of course), and STILL NO PSP CORE! I redownloaded the 32 bit version with the same result.

I cannot find them. I am on the current version, I have tried the 32 bit version, the 64 bit version, and the Nightly version. Where on earth are these cores?!

See here for details:

@ GemaH: I don’t remember where I saw the instructions, but think it was a forum post that linked to the Dolphin core. It had instructions stating where to put the Dolphin “Sys” folder which it said was supposed to be located in the RetroArch/System folder.

  1. Sorry to bump, but still no answer on this. I am unable to find any info regarding how to change core settings. When I try to do so in RetroArch, I simply get told “there are no options for this core.” This happens with every core. So how exactly do you change a cores settings?

3 + 4. I managed to get these working for Mario Kart 4 (double Dash) and Mario Kart 7 (3DS). But I had to load the core first from the main menu. Why can’t I just load the game without having to load the core first? This approach doesn’t work for Mario Kart 6 (Wii) though. I just get notified that this file could not be loaded from playlist.

I have just tried to load MK4 direct from the playlist and it worked with no core preloaded. However doing so with MK7 gives a notification: Failed to open libretro core.

If I try to use the experimental Citra core, RetroArch crashes.

Any advice would be appreciated :grin:

You have to load a core+content first. The core isn’t really loaded until a game is running.

3 + 4. usually this is caused by something wonky in your playlist, such as an incorrect core set for a file. I would delete the playlist, re-scan and then go to settings > playlist and manually set the default core for it.

If dolphin works, citra usually will, too, so we’d have to see a log to know any more. For the record, citra-libretro only works with decrypted ROMs.

I already tried that. Can you give precise instructions so I know exactly what to look for, or where I need to look to change this please.

Well, I do have a single playlist that contains all the Mario Kart games 1-7 and some hacks of MK1, but each game in the list has been set to it’s own core. Could that still cause an issue?

I know about decrypted ROM’s wrt Citra. Done and dusted :wink:

ah, so it’s a custom playlist. Okay, you won’t be able to set a default core in that case.

I guess your next best step is to try getting a log of a failure-to-load and see why it’s actually failing. That is, whether it’s loading the wrong core or what.

Well, dunno if it helps but i have no “Sys” folder in RA/system folder. Dolphin core works with just the dolphin folder in the saves directory.

I’m using the dolphin core from the links in this thread.

The Dolphin core has created a dolphin-emu/User path with all the default files needed for Dolphin’s users. But the Sys folder is not a part of this, If you check out the standalone Dolphin app folder You can see that User and Sys are two seperate folders. The Sys folder is about app and game settings for the User rather than saved games etc.

As this was causing a problem and trying to find out how to do it for weeks now, I thought it might be helpful to others to know how to disable Multi-Tap on PCSX-rearmed core for PS1 games.

  1. Start any game.
  2. Open the Quick Menu during the game.
  3. Select “Options/Show other input settings” and switch it to “ON”.
  4. You may need to exit the game completely then run it or another game to actually show the Multi-Tap options. Go back to “Options”, Multi-Tap 1 and 2 entries should now appear so you can turn these both off.
1 Like