Verbose mode not working when logging to file is enabled

I don’t know if something was changed in the latest builds, but on RetroArch 1.9.0 x64, the Log Console window is empty when log generation is also enabled. I tried -v and --verbose parameters, before and after --log-file .\retroarch-log.txt, but nothing works, the log is created but no verbose output whatsoever. The same behaviour happens when log_to_file in retroarch.cfg is true, it disables verbose mode even if log_verbosity is also true. I have to disable log to file in order to have verbose mode working again.

Before updating to the latest stable build, I had 1.8.0 installed IIRC and the console window was outputting the log just fine when logging to file was also enabled. Are both options mutually exclusive now, or is it a bug? I installed 1.9.0 on top of 1.8.0 like I always do, never had this issue before.

edit: I noticed that -c or --config parameter also disables verbose output to the console, I don’t recall this behaviour on 1.8.0 either


I solved the issue by deleting config files, guess the build I was using was too old and causing conflicts after installed a new version on top of the old one, all is good now!

1 Like

Ah, thanks for posting your solution. I’ll leave this thread here in case someone else has the same issue.

1 Like