Video -> Screen Resolution Setting not being applied

Hi,

I have an older PC I am setting up as a emulation PC. I set the resolution to 1920x1080, 60Hz. However, when I connect it to a 4K monitor, it ignores that setting, and runs at 3840x2160, and there is a significant drop in frame rate.

Both retroarch.cfg as well as the core cfg contain the lines

video_fullscreen = “true” video_fullscreen_x = 1920 video_fullscreen_y = 1080

How do I make it enforce these options… and NOT revert to 4K resolution when starting a game?

Make sure you have the option for “windowed fullscreen” set to off, as well. In the config, it’s:

video_windowed_fullscreen = "false"

Thanks @hunterk

That fixed it. Now the issue is that RA does not restore the desktop resolution upon exit. Any way to make it do that?

I don’t think RetroArch has any mechanism for setting it back. You would need an external utility for that, AFAIK.