Weird USB controller issue on some cores only

Hello, I have recently changing my installation from PI to Windows. So I know a bit Retroarch. Fresh install of Retroarch stable on Win10. Everything seems in place. Except my 2 usb controllers. It’s 2 dragonrise USB controllers (recognized as “Retrolink N64 controller” by autoconfig).

Everything is working correctly in RA menu, and also in cores MAME & FBNeo. But when I launch another core, for example Stella for Atari 2600 or Nestopia UE for NES, joystick stops working.

I see clearly the 2 popups of the 2 detected controllers when the core is launching, so autoconfig works. But in game, no more (but hotkey works!), but joystick doesn’t work.*

Looks at debug logs, can’t see difference between MAME (working) and Stella (not working).

Is anybody has an hint about this ?

Thanks in advance.

1 Like

ok Solved it. Remap the joystick directions and it works now. Strange, as the autoconfig seems working (without remaping) as it works in some cores. Now it’s works in all cores when remapped.

1 Like

I thought you might have the answer for my issue. Controls work in RA menu and some cores but I loose the joystick on my arcade cabinet in N64 and Gamecube. Tried remapping and joystick still doesn’t work in those cores. Works great in others.