Where do we post MAME questions


#1

I don’t see a MAME subforum. I need helping getting MAME to work on my Retroarch. I first started it out and was able to play Ninja Turtles and Captain Commando. I was not able to play Hook so I went online trying to understand more. I read about needing Bios so I copied some bios to my system folder. Now none of the games work. I deleted the bios and nothing works still. I could not find anywhere that said what the bios are supposed to be labeled as. Is there a retroarch guide on MAME installation and getting it to work with all arcade games? I might need to uninstall MAME core and hopefully that will fix this.


#2

We have a bunch of MAME snapshots and if you want to use one of them, you’ll need the ROMs that match that set. Ditto for FBA. The MAME core without a year in the name is up-to-date, so you use up-to-date ROMs with it.

BIOS files don’t usually go into the system folder like most cores. Instead, MAME typically sees them as “parent ROMs” which means it tries to load needed files from them, so they need to be in the same directory as the ROM you’re trying to load.

As a rule, if stuff isn’t loading, you’ll need to post a log for us to help you.


#3

For all MAME Cores, you need to go to the “retroarch/system” Directory, create a matching Folder (example - mame2010 or mame2014, or mame for the 197 Build) and place all BIOS, Cheat, DAT Files in this Directory.

However I do have a Issue with the MAME Core (0.197) - On Android with a XInput or DInput Controller Input, what Button will trigger the MAME “Tab” Button to show? Tried all the Buttons, but 1 sent me to the MAME Game List Menu to select a Game, but it only showed ALL the Games, and I could not get out of it.


#4

I’m sorry but this doesn’t sound right to me. I have a perfectly working Mame 0.202 and all the roms, bios files go in the same folder.


#5

Is there a naming format the bios should be?


#6

It’s confusing because I believe there are some true BIOS files that can/should go in system/mame[whatever]/ but there are others like neogeo.zip that are like parent ROMs and need to be beside the game ROM.


#7

The libretro system folder is generally for samples, cheats, and the history.dat file with the MAME cores. Details may vary by core, but that’s how it should me.

“MAME BIOS” zipfiles should be in the same folder as the arcade romset you are tying to play in keeping with MAME convention.

At any rate there are only docs for MAME 2003/-plus and MAME 2010 but they illustrate the general approach.

MAME 2003 and 2003-Plus have the same directory scheme, documented here: https://docs.libretro.com/library/mame2003_plus/#directories

MAME 2010: https://docs.libretro.com/library/mame2003_plus/#directories


#8

This is the exact same issue I’m having!


#9

I deleted MAME and reinstalled it. I also didn’t put any bios in the folder. It’s like others said I have to have the up to date ROM with the up to date MAME. One thing I learned is the ROM has to be labeled an exact word. For example TMNT2 has to labeled that way. I renamed it to TMNT Turtles In Time and then it didn’t work any more. So now I can get hook to work because I changed that name. Now I need to figure out how to get the 4 player version of hook. I can’t figure that one out yet.


#10

Not to be contradictory, but, after testing it using ROMs exclusively from the new 205 set and matching BIOS set, I’ve had no trouble running games that aren’t inherently broken romsets (from the non-merged set) to begin with in all of the MAME cores.

Mostly, I did this because MAME operation has always been a bit obtuse compared to other emulators/cores (And not surprisingly so, given that it’s a single emulator trying to manage to pretend to be hundreds of different hardware sets, so, not a complaint, just an observation), and was oddly and happily surprised that that part of emulation went flawlessly.

The sad thing, that is completely off topic, that I’ve noticed is that the RetroArch scraper doesn’t seem to pick up the non-merged names for the thumbnailing function, but, that’s about it other than not being able to configure arcade controls, which has nothing to do with either the ROMs or the basic Core function.

Yeah, I know, #coolstorybro anecdotal information

As to where to get a particular ROM or ROM set, [NVM, just read the code of conduct, was going to link to it], I will just say there are several large, open groups that exist exclusively for regular releases of the MAME romset with improved and historic rom images, and I guarantee 4player Hook is among them.

… Which hopefully you’ve found by now, three months later.


#11

As far as BIOS detection goes, I have done nothing special other than have a separate folder in my ROM directory to keep them apart from the mountain of actual game ROMs, and, as per my previous comment, have had happy operation across the age of cabinet gaming.

Mileage may vary.

But, if you have Retro Arch scan the directory your arcade ROMs are in, it should pick up the BIOS dumps also.

Don’t quote me on that, it has just been my experience thus far. HunterK probably, relatively, has the inside track on that info.


#12

I’m the person who has helped prepare the MAME romset scanning databases for MAME 2000, 2003, 2003-Plus, and 2014.

If you have a Full Non-Merged romset that has been TorrentZipped and it doesn’t scan, I’d be interested in knowing what the romset is named and its CRC.


#13

Well, looking further into that particular issue, it seems the matter is that Retro Arch isn’t properly/fully downloading the thumbnails zip, and that might be the real issue. The set is the Non-merged .205 off PD(shortened to obfuscate destination for forum rules).org.uk. I’ll get you the CRC when I get home and check my tracker


#15

I’m sorry, I didn’t catch that you said thumbnails in your earlier post.

I also helped prepare thumbnail packs up through MAME 2014. Not all of those thumbnails will match a newer version like MAME 0.205 but – as you say – if the pack is downloading at all there should be many that do match and therefore do display thumbnails.


#16

Yeah, that was the thing (I realize we’re drifting away from the initial subject so if this needs to move to private messages or a new thread that’s fine). Right after posting, I went in to manually try and rename the thumbs and in-game screenshots to match a few of my ROMs since I know that’s how the association works (and that that is better than renaming the ROM itself for some obvious reasons) and, hey, no thumb folder. I know I’ve initiated and completed the download at least once, but, I tried it again.

RA goes through the process like with every other thumb zip, completes the download… and then, poof.

Now, granted, I know this is a huge ZIP given that it’s got three thumbs for about 35.000 ROMs, so, I expect there’s some decompression time.

But there’s not even a temp file to find (Unless RA uses some hex naming schema for temp files in process). It just vanishes.


#17

The hash for that CRC is 682f43d31a58cfbe3f9b158d21f8b90ea43fe9c5 for the MAME 0.205 ROMs (non-merged) torrent, in case you were still wondering. And, your point makes sense. I checked some of the romset file names with a much older batch I have remnants of and most of the ROM names seem to line up so I would imagine the thumbs translate, but, the point is moot until I can get the files to actually apparate.


#18

You can try downloading the MAME thumbnail pack directly from http://thumbnailpacks.libretro.com


#19

Ah! That’s exactly what I was hoping for. Much thanks. I knew there was a directory for it, I just couldn’t find it


#21

As a side note: Worked just fine with manual download. Took several hours, but was totally worth it. Thank you!