Which set of cores for Retroarch on Ubuntu on Pi 4?

I set up a Pi4 running with Ubuntu (w/ Mate desktop) and I installed Retroarch (PPA). There are no cores installed and the core downloader doesn’t work (as stated on the site, so no problem here).

I tried downloading a few cores manually and install them, but they don’t work, so maybe I grabbed the wrong files? I tried both the armhf and the neon variants of the cores. Aren’t those the correct ones (Ubuntu 64bit on a Pi4) ?

I feel silly asking this. This shouldn’t be somthing to have problems with. A small push into the right direction would be appreciated!

Thanks a lot! Didi

You need arm64 a.k.a. aarch64 cores. They should be available to you via the package manager from the same PPA, look for libretro-*

If they are not available you will have to compile them. The armhf and armv7-neon-hf cores are 32 bit.

Thanks, makes sense! I’ll have a look.

EDIT: didn’t have any luck getting them from the PPA, but started compiling a few cores. Works! Thanks again!

PS: any particular reason why the Linux Arm64 ones aren’t included in the libretro buildbot directories?

We just aren’t set up for it currently, but I believe it should be easier to add it to our new infrastructure model, which should be going live soon™.

1 Like

can someone compile a tutorial to compile/build cores for Ubuntu Mate on Pi4?

Most of the time, it’s just:

  1. clone the repo
  2. make