Wiimote not working with 1.9 and latest nightly

I just dug out an old Will and started playing around with it. I put RetroArch 1.9 on it and I can load games and cores, but the Wiimote will not work in games. I can control the menus but no game functionality. If I change the default mappings, it will work.

Example - load up Super Mario World with SNES9x. The “+” is mapped to start, but it doesn’t work. If I change it to “B”, I can press start, but I can’t move or use other buttons. If I map DPAD Left to DPAD Right, and vice versa, I can move the opposite direction to what I’m pressing. If I change everything back, none of the controls work again. I didn’t try the remapping using MAME, but I had the same issue with no buttons working.

Also going into settings for a core to map buttons doesn’t work either. You get the timer to press the button you want to map to but it won’t take the input. Yet you can use the same buttons to navigate.

I also installed the 9/3 nightly and had the same issue.

Any advice on how to fix this?

1 Like

I’m having the same issue. Rolling back to version 1.7.0 worked for me, but I’m still desperate for a fix seeing as 1.7.0 is missing lots of quality of life improvements.

I also confirm the problem. This happens even if i move a core from retroarch official to Retroarch-hexaeco. All hexaeco cores working normally but the ones pulled from RA don’t.

I am also having a similar issue. When I turn on a Wii remote or WiiU pro controller, RetroArch recognizes the device and assigns it to Port 2. However, I cannot navigate through the menu or play games with either of these controllers, despite the fact that the buttons appear to be mapped correctly.

I am using RetroArch version 1.8.9 for the WiiU with the cores: gambatte, mgba, nestopia, snes9x. I have tried updating the controller profiles, deleting my config file and letting RetroArch generate a new one, and manually mapping the controllers under input settings.