Windows Nightly discussion thread


#321

Using 1.6.7 on a Windows 10 desktop computer

Audio DSP Plugins no longer seem to work. What happened?


#322

update to nightly release as this issue has been fixed a few commits ago.


#323

Noticed that after a bit more google searching.

Sorry. :smiley:


#324

I’ve recently downloaded retroarch for windows 10 using the windows_msvc2010/x86_64 version in the nightlies folder. I have been having some difficulty downloading or updating cores, as every time I had attempted I would get this message: "Task Failed: Downloading ‘.index_extended’ " and no cores would be displayed.

I noticed as I was searching to solve this problem that the msvc_2010 folder does not have a ‘latest’ folder with cores in it which is where my config file is pointing to for the core updater buildbot URL. I made a change in the config file so it would point to the ‘latest’ folder that is in the windows/x86_64 folder instead and, after loading that config file, I was able to generate the list of cores.

I changed:

core_updater_buildbot_url = “http://buildbot.libretro.com/nightly/windows-msvc2010/x86_64/latest/

to

core_updater_buildbot_url = “http://buildbot.libretro.com/nightly/windows/x86_64/latest/

Is the window_msvc2010 folder supposed to be missing the ‘latest’ folder?


#325

I just signed up here to warn people about the download for retroarch win10 x64, I would create a thread but I have no idea how to go about it.

I downloaded it this morning 25/10/2017 and Comodo picked up Cryptolocker.K inside the installer.

No damage was done as I was running it inside the container, But thought I better warn people about this.


#326

Hey Masterdat, thanks for the heads-up. Can you give us any more details about which download, specifically?


#327

It’s most likely a false positive


#328

How add on a menu option shtdown/ restart pc??? Has a possibility?


#329

I just installed the 11-9-17 nightly and I’m able to add ROMs via a directory search without issue.

As I describe here:

RA seems very picky about using specific validated ROMs, but as long as they check out in clrmamepro or Romcenter, RA adds them via a directory search for me.

Edit: Just realized your reply was from a release where it was briefly broken. But for other folks who are curious, it’s working now as far as I can tell.


#330

Hi, I have been using retroarch on windows with attract mode for a while now, and everything was ok, until I updates to retroarch to 1.6 and later. FBA just stopped working with attract mode. Every other emulator works including FBA2012, and FBA works directly from retroarch GUI, but not from attract mode. This is weird, I hope anybody can help.


#331

If it works from the RetroArch GUI, you must have something wrong with your launch line in attract mode.


#332

The launch line used to work before, it works for FBA2012 (I just replace the core name in the launch line and it work), and it is the same launch lien I’m using for other emulators (all work fine), here is my launch line:

executable G:\ARCADE - MAME SPECIFIC\retroarch args %file -L cores/fbalpha_libretro.dll “[romfilename]” rompath G:\ARCADE - MAME SPECIFIC\fbaroms romext .zip;.7z;


#333

Say, how can I make RetroArch Nightly’s Citra Canary Core recognize my shared_font.bin file?


#334

On a friend’s computer, I downloaded nightly build and the latest stable version, tested it and everything worked perfectly. But when I went to test in my notebook, it did not work as expected.

I gave BEX error, did some research and disabled the DEP for the application. The BEX error is gone, but the retroarch gives APPCRASH in both versions.

Can anyone help me to solve this problem?

The following is the error for knowledge: https://pastebin.com/EWiehUKh


#335

Hi, I am not sure how to start a new topic. I am a new member of the forums. I have a USB controller adapter for my original Dreamcast controller. The controller works fine with my other emulators and games that are not run through RetroArch. I have tried to input and map my controller for Atari Jaguar games. I am playing them through Launchbox/RetroArch. The input set up is not working for me at all. It is not changing any input keys I am pressing on the controller when prompted and my controller is not working for my Atari Jaguar games. The games load fine. I am not sure what to do. I have watched several tutorial videos on how to set up controllers on RetroArch. Can anyone please help?


#336

Hello! I don’t know how to create my own topic, so I’ll post here. I have installed Windows 7 on my PC and installed RetroArch over it. RetroArch based on MSVC 2010 doesn’t start at all, BUT RetroArch based on MSVC 2003 starts and even downloads cores from its repository, but it can’t load any of them to use. I have created a topic on Lakka’s GitHub - https://github.com/libretro/Lakka-LibreELEC/issues/312 You can find logs there, Lakka goes to Bootloop when I am trying to boot it.


#337

I love this multi system emulator… That said, there is a huge issue regarding the ability to select which video driver to use per core or game. This is not a criticism and I am sure someone else some place said the same thing in the past (though I could not locate that thread). Is it possible that in the future Retroarch will allow for specified driver settings per core and per game? It would make life much easier. I have seen where some people use front end applications to get around this limitation, I would rather not have to do this as it gets messy.


#338

It’s something we would love, yes, but we haven’t figured out a way to do it yet.


#339

Hi I am new here so please bear with me. I just downloaded the Retroarch 1.7.3 Nightly version. I want to play PSX games with it, but I can’t seem to get the cores for PSX to work. I downloaded the one from Libretro and it doesn’t load. I’m using a Windows 10 laptop with Intel Core i5 and the graphics driver of Intel HD 3000.


#340

what “the one”? You mean RetroArch itself? Or the core(s)?

When you say “I can’t seem to get the cores for PSX to work” do you mean just those cores? Do others work?

My guess is that RetroArch isn’t loading for you, which is a problem with your GPU and driver in Windows 10. If you open your retroarch.cfg in a text editor (notepad++ is free and works well), add the following line: video_driver = d3d9

You won’t be able to use the beetle-psx-hw core with that driver, but RetroArch will launch and work.