Xbox 360 / one controller not detected on my ubuntu 18.04

Hello, I am a total noob but retroarch seems great. I have one problem, though: none of my xbox controller is detected. I read many messages but it seems that they are not related to my problem (it is rather about controller malfunctions). So, to be precise: retroarch simply acts as if no controller were plugged in, no matter what driver I select. Moreover, my controllers works just fine on steam, for example. What should I do?

Are you using the snap package? If so, you probably need to connect these plugs:

sudo snap connect retroarch:raw-usb
sudo snap connect retroarch:joystick

Also, make sure Steam is closed, as it hijacks gamepads and makes them do weird stuff.

Well, I had a configuration problem (my keyboard was not detected as well), so I reinstalled retroarch… And now my controller works… (?)

You can use the xboxdrv package if you want. so you controller does work now?

Yes, my controller works… I don’t know what happened.

Reinstalling did not solve the problem on my side, however I think I’ve narrowed the problem to some service that needs restarting while Retroarch is running (on Ubuntu 20.04).

I have to note that the controller seemed to work just fine except in retroarch. (I could plan Stadia games (through chrome) with not issues. However when I launched retroarch, the controller was not even detected)

I followed some steps from this website (How to Set up an Xbox One controllier in Ubuntu): sudo apt-get install xboxdrv sudo systemctl enable xboxdrv.service sudo systemctl start xboxdrv.service sudo nano /etc/default/xboxdrv #removed the last “/” from the website or else it didn’t work [xboxdrv] #added these lines silent=true next-controller=true next-controller=true next-controller=true #quit and save sudo systemctl restart xboxdrv.service

And it still didn’t work. BUT when running: sudo systemctl restart xboxdrv.service When Retroarch was open, it actually detected the controller.

Now it works but I need to launch retroarch, relaunch the service manually and then set the buttons everytime I want to play.

Looking for any fix right now to make the process better.

Any suggestions are welcome!

Hello! I’m having a related problem, any advice is appreciated:

Whenever I restart Retroarch or load a game, my Port 1 Controls Device automatically changes to Disabled, until I unplug and re-plug in my Xbox 360 controller. If the controller is plugged in and lit up as player 1 before opening Retroarch, it is not listed under Device Index until I unplug and re-plug it in. When I re-plug in the controller it autoconfigures and works fine, but this is annoying to do each time I load into Retroarch and/or into a game. (Note this only happens with Retroarch - the controller always works fine navigating Emulation Station).

I am running this on Ubuntu 22.04 and use Emulation Station. I installed the snap package of Retroarch (per instructions on the Emulation Station site).

I have tried:

  • run retroarch directly (not through emulation station)
  • update assets
  • update controller profiles
  • tried using every driver under input and controller
  • deleted autoconfig folder, restarted retroarch, updated controller profiles
  • deleted retroarch.cfg file and restarted retroarch


The snap does this for me, as well, though I haven’t really dug into it to see if there’s anything I can do about it. I would suggest trying the AppImage or PPA packages, which will not have any sandboxing interfering with things.

1 Like

The PPA package works perfectly, thank you!!

1 Like