Xbox One Controller has stopped working


#1

Hello,

Just recently I found that my Xbox One controller had stopped working. With the same version of RA (1.6.7). I didn’t do any changes. Only xbox 360 controller is working at the moment. The only way I can use Xbox One controller and only in RA menus is to turn on option “Both users can control menu”. RA detects the controller fine. All buttons are set correctly. It just don’t allow me to control anything in game with any cores.

I’ve gave it a try with the latest nightly build but it’s the same.

So I think maybe some recent Windows update broke RA functionality. I use Win10.

Does someone has the same with Win10 and Xbox One controller?


#2

It sounds like the xbone controller is not the first controller it detects, which is what causes you to have to enable the “all users control menu” option as it has become ‘player 2’. And the fact that it’s used as a ‘player 2’ would explain why it doesn’t let you control things in-game. Perhaps if you try a 2-player game, then that pad would work. You must already have something else plugged in that’s being claimed as player 1, or perhaps something in your config has gone wrong (you could try renaming the old one temporarily).


#3

That’s the first thing I thought. But unfortunately Xbox One controller detects as 1st. So I can’t control RA UI unless I enable “all users control menu”. Games which support menu control by seconds player act the same way (Sonic the Hedgehog). I can’t control only a second character.

I’ve tested it with fresh instance of RA extracted from an archive. No luck. And even if I physically turn off second controller (xbox360) my Xbox One controller still doesn’t work. Despite it detects fine by RA as the 1st.


#4

When you say first, do you mean port#0 or port#1? Because zero is the first player. What do you mean by “act the same way”? Also, have you tried using the controller via both wired and wireless? I would also test other (non-RetroArch) games and see if they still work.


#5

I mean it detects as Player 1 (#1). While my other controller detects as Player 2 (#2). Ports 0 and 1 respectively.

But anyway I’ve manage to fix the issue. It looks like my Xbox One dongle has stopped working properly for some reason. I’ve reconnect it and now the gamepad works fine.

Thanks.


#6

First time user running RetroArch on Windows 10. I have an Xbox one controller and only my D-pad, analog stick (only in the RetroArch menu), Start, and Select (Back) buttons work. The A, B, X, and Y buttons do not register at all (Menu or in gameplay), even after trying to manually configure the controller. The computer recognizes the buttons if I use the controller elsewhere. Any suggestions on how to fix this?


#7

Do you have Steam running? It hijacks gamepads and does weird stuff with their input.


#8

Not sure what a Steam is. If I do, I am not running it purposefully. The Xbox Game Mode kicks on when I plug the controller in, if that’s what you mean.


#9

You don’t know what Steam is?


#10

Nope, never used a site like that. I am just trying to find a medium to play old school NBA Jam and Blitz for a bachelor party.


#11

I am having the exact same problem, except on windows 7…desperately searching for solutions, but I won’t be able to make a thread for another 5 days.


#12

I have a similar problem with the Nvidia Shield TV controller. I use Nvidia Gamestream to stream Launchbox/BigBox (retroarch is my main emulator in Launchbox) to my Nvidia Shield boxes. Everything will work perfectly fine and then my controllers will stop working altogether. I will have to create a topic on this soon.


#13

I updated to a nightly recently and noticed my Xbox 360 controller was being recognized as an: 8BitDo GBros. Adapter (Wii Classic Controller Layout) which made functions of the stick not work properly.

The following change fixed the problem for me:
Settings -> Driver ->  Joypad Driver ->  dinput
Main Menu -> Configuration File -> Save Current Configuration
Quit and Restart Retroarch

With the Joypad driver changed to dinput, the joystick is again recognized properly as an Xbox 360 controller and working again. It was always set as xinput. Have no idea why this was changed by Retroarch?


#14

Someone submitted autoconfig profiles for the GBros Adapter but it included generic vid/pid information that conflicted with the 360 pad’s vid/pid (and many others, actually).

I replaced the vid with what I believe is the correct one and commented out the pid, so hopefully that will get you fixed up if you update your autoconfig profiles. If not, let me know.


#15

Thanks for the info. Yes the input_vendor_id = “1118” of the [ 8Bitdo_GBros_BT.cfg ] and [ 8Bitdo_GBros_USB.cfg] matches the Xbox One and the Xbox 360 controllers vid.

I updated the JoyPad Profiles thru the Online Updater and it’s still the same problem. However deleting the 2 GBros files (mentioned above) from the autoconfig/xinput directory correctly identifies the Xbox 360 controller as an Xinput Controller when setting the Joypad Driver to xinput.


#16

Alright, thanks for testing. I commented out even more of the GBros conflicts, so if you get the chance to test it later on, I’d appreciate it. If it still conflicts, I’m afraid I’ll just have to nuke the GBros configs altogether.


#17

Just downloaded now the updated JoyPad Profiles…fixed!


#18

w00t! thanks again for testing!


#19

Hello, sorry to hijack this thread, but I new and I cannot make a new topic.

I’ve followed all the advice here, including reinstalling, and still my 360 controller is not longer being recognized. I left Retroarch running over night, I guess my computer reboot for some reason and now no controller.

Also whenever Retroarch no longer responds to the ENTER key on the keyboard, and when I exit it, the mouse no longer functions. It was working just fine a few days ago, I’ve made no changes whatsoever.

Can someone tell me what I need to backup so I don’t have to scan all my games again? That took several hours and I’d rather not repeat it. I’m just going to delete the whole folder and start fresh I guess.