Xbox One Controller - Lakka - PC

Hello, I’m having issues configuring the Xbox One controller (wired) to Lakka. It recognizes the controller when I plug it in and the auto-binds look correct but the controller is unresponsive.

I’ve tried hitting the Xbox button to start the controller up but nothing. After a minute or so the Xbox button will flash but do nothing after that.

I’m running Lakka live from USB flash drive (into USB 3.0) on a PC with A6-7400k processor and Asrock A88-g/3.1 mobo.

Build date shows Jun 2 2016 and Git version f8b1f05 but when I try to auto update to the July 17 build it fails size check on reboot.

I get the size check failed when manually inserting the July 31st build from github into the Update folder as well. I’m assuming my old build is why the controller isn’t working?

I think newer builds have moved to an updated kernel that handles xinput controllers better. But yes, the size thing happens because the newer update is larger than the old build. I’m not sure how best to handle that but I think there were some threads about it in the Lakka subforum.

Thank you for the reply.

My Googlefu is really weak for some reason today. Is there a way to resize the boot partition in SSH?

If I would have known I’d be messing with this so long I would have just done a fresh install. It looks like the latest image for new install on lakka.TV is July 17th.

Did a fresh install on a different USB drive from the following link:

I get the same build date on system information so it is probably the same image I used for my original. Xbox one controller still doesn’t work and I still get file size check failed when I try to update using any method.

Can you try one of the builds from here:

[QUOTE=hunterk;44003]Can you try one of the builds from here:[/QUOTE]

This worked! Thank you for your help. I’m in process of doing a clean install now and transferring over my games via network.

I have similar issue. My Xbox One controller wired (Model: 1422336-01) to Lakka. It recognizes the controller when I plug it in, but the controller is unresponsive.

I’m running Lakka from Samsung 64G SD Card on a OrangePie Lite.

Is there anyone can help please?

I am also having an issue with my wired xbox one controller. I plug it in and it doesnt even turn on. Usually it powers it up and the xbox button lights up. When I plug it in nothing happens. I have tried multiple cables and still nothing.