Xbox One controller stopped working?

The last thing I did was change the autoconfig setting in input. I was trying to find a fix for my digital to analogue setting not saving between games. Anyway, I used my controller to navigate to CastleVania: Legacy of darkness on Parallel. I load the game and it tells me about memory pack not connected. I think “oh, right…” and press the xbox button so I can fix that and… nothing. My controller no longer works in RetroArch 1.8.7.

The controller is still on and connected via bluetooth, and it still works in other games. I tried deleting the config file to start anew, to no avail. I’ve searched around and haven’t found any relevant topics.

Do you guys have any ideas?

Did you turn off autoconfiguration? If so, turn it back on. Also, while you’re in settings > input, stop by ‘port 1 binds’ and hit ‘default all’.

I have tried that, no luck. I forgot to mention that when I would connect my controller before it would say “xbox one controller connected” or similar, and now it says “xinput controller connected” and it maps to user 1. Shouldnt it be user 0? I have even tried enabling all users to control the menu, no dice.

user 0 and port 1 are the same thing. We just changed the name to be more easily understood.

Well, I was completely stumped by the issue. I ended up having to completely wipe the install and start from scratch. I was able to move most of my save data over, but such is life :slight_smile: What a weird thing, though.