Xbox One Guide Button No Longer Opening Menu

controller

#1

Suddenly, my guide button no longer opens the RetroArch Menu. I haven’t changed anything, so I’m confused as to how this could have happened. I tried replacing the Xbox_One_Controller.cfg and XInput_Controller_User_1.cfg files with new ones, but it still doesn’t work. I also tried editing the files to enable the guide button, but it’s entirely possible that I don’t understand what I’m doing. Is there some sort of guide out there that explains how to enable this function on xbox one/360 controllers. Thanks in advance.


#2

It should just work out of the box. If it does not work for you, it’s probabely a Windows problem on your end (I’m assuming ypu are on windows). I don’t think it’s a problem on RA.

Make sure Steam and/or Xbox app does not have this button locked for internal use. I suggest you go on your gamepad configuration on windows and test this button works on the gamepad wizard.

Greetings.


#3

@cubatilles, You were absolutely correct. I should have also mentioned that I was running RetroArch on Windows 10 and would occasionally get a Microsoft Visual C++ runtime error stating that the program had closed in an unusual way. After some troubleshooting, I discovered that this error happened EVERY TIME I TURNED ON THE XBOX ONE CONTROLLER. I googled around some more and tried a few solutions, but THIS is the one that fixed my problem. The guide button now opens RetroArch’s menu and everything runs perfect again.

https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system


#4

I spoke too soon. The runtime error came back, and after a little searching, it appears to be a conflict with the Microsoft Xbox 360 accessories program and the newer xbox one wireless adapter.

https://answers.microsoft.com/en-us/windows/forum/all/runtime-error-message-when-using-xbox-one-wireless/f166843d-fc98-4e46-a6a9-187de1089f05

I uninstalled Microsoft Xbox 360 accessories, and so far so good. I’ll post again if the issue persists. I’d also like to find out if I can use both wireless adapters, since I have far more 360 controllers than One controllers.