(Xbox Series X) I can't load games from my external drive

I am trying to setup Retroarch on my Xbox Series X, but there are a few problems. I uploaded “My File Explorer” and “Retroarch” into my Dev Mode and followed tutorials to set it up, but when I try to load games from my USB drive to Retroarch it does not show my files in E:/ and when I try to acces Retroarchs database trough the File Explorer it does not show the File “packages” which I need to access it. I already contacted the Xbox Support and was told that they don’t have access to the Retroarch Servers so the problem has to be on your side

2 Likes

I have the same problem also. I just got a Series S and I wanna play Retroarch on it, but I really need an external drive to load all my ROMs and ISOs on it.

I used the standalone PPSSPP emulator and it can load from my external drive just fine. My external drive also says E:.

I’ve check every single drive letter in Retroarch. None of them detect my external storage.

Is there anyone that can help? All the tutorial videos on YouTube say you can load from an external drive, but they don’t say how.

Microsoft updated something in dev mode, for internal storage all files used to be available at S:, now is D: and has a few bugs. As for external, I’ve read somewhere that there’s an option to show hidden files, I haven’t testes it though.

Since I wrote this post I contacted Mods from Retroarch and they said that the problem is not on their side either. So actually it is all Xbox’s fault. After contacting the Xbox Support countless times they said that they are working on fixing the problem, but to be honest I kind of doubt that. I think all we can do is wait for an update…

I have the same problem. With RetroArch 1.9.0 it worked. Now I installed 1.9.14 and .10 to try and can’t access. Did you get any fix by now?

Try this:

Connect your drive to a Windows PC, go to File Explorer and right click on your NTFS drive, then do the following:

Properties > Security > Advanced > Add > Select Principal > Advanced > Find Now > All App Packages > Ok > Tick Full Control > Ok > Enable Inheritance.

And you’re done!

1 Like

Hello:)

Having a problem with RetroArch (Series X w/ dev mode), basically in normal mode (non-dev) my XBOX recognizes the external drive as medium and all files are being displayed. Retroarch however does not display any of the files, I can’t seem to be able to access the external hard drive in dev mode. It’s being displayed, however I’m starting to think microsoft lately changed / limited Dev Mode file system? Already tried to enable the “display hidden files” option in Retroarch - Happy about any help. :slight_smile:

I’am pretty sure Microsoft limited the Dev Mode and I gave up on updates that are fixing the problem. However I recently got an answer on Reddit where I’ve been told that Retroarch is available on Retail Mode without being Whitelisted. After setting everything up, it turned out that the Retail Mode didn’t have any of the problems the Dev Mode had. The external drive got recognised and I can load the Files onto Retroarch. For further options regarding the Database of Retroarch, I used a FDP App to access the Files from my Laptop. That way I could load the games or the Doplhin emulator onto Retroarch without needing an external Drive. So I basically bought the Dev Mode for nothing…

Hey Wondercase, I almost gave up hope as well, however I tried the mentioned steps above:

Make sure to enable the inheritance setting, also make sute to display hidden files im RetroArch file explorer, in case it still doesn’t work.

And I can now access the drive in dev mode. Running version 1.9.10 (RetroArch). I’m using the front usb port.

Hope this works for you :slight_smile:

2 Likes

I also tried that hard drive settings hunterk answered me. It worked fine. Thank you. Now I can access all files on the hard disk. I took the USB port on the back.

1 Like

I have an Xbox Series S with Dev Mode. And Retroarch. I have Loaded my Games fine. Here’s a Link to a YouTube Video I used. I don’t use an External HD. I have them on my PC. And Copied them to my Series S. Over Wifi. I have 100GB of Roms on my Series S SSD. Retroarch works. I’m currently trying to add Thumbnails (Box Art, Start Screen etc…) Watching a Video on YouTube…Here’s the Link. Hope it helps. You can always copy the games from your External HD to your PC. Then copy them to your Xbox (Wifi.) Then delete them off your Pc. When You’re done.

[Xbox Series X|S] How To Install Retroarch! Ver 3.0 - Dev Mode - YouTube

You are the man sir, thank you so much. i tried every thing, and nothing worked tell i found the info you shared. I was almost going to take the xbox series x back to the store. so anyone having same problem with drive not being seen on dev. this is a 100% fix, works perfect. thanks again.

1 Like

Is there a way to do this on windows vista?