2 or 4 controllers on Dolphin emulator through RetroArch


#1

Hi guys, Trying to setup my Dolphin emulator through RetroArch with more than one controller. It seems very difficult as RA does not let me configure more than one controller no matter what I do in the quick menu “per core” setup.

Main problem is that Im only allowed to map for one controller input at a time. I can change device type on lets say device 2 and then it lets me change mappings for device 2. If I then go to device1 and change the device type it suddenly lets me change mapping on device1 but not on device2 anymore. The mapping itself is the same buttons when Im doing this but just moves over to another device.

Is there any trick to making specific controller setup with more than one controller? I went into the Dolphin.ini file to change the SIDevice value to 6 for all four controllers I want to configure without that helping much.

We tried also to configure device1. Then quit RA and find the remapped config file. Then to copy settings for device1 and duplicate it to device2, 3 and 4 without any luck. Only thing that then happened was the mappings moved in RA GUI from device1 to device4 leaving all other mappings blank like before.


#2

I’d like to know this, too. Retroarch Dolphin only seems to notice one mapped controller for me in games like Timesplitters 2, Mario Party, Mario Kart, etc.


#3

It’s more or less explained here


#4

I do read in some forums that users have changed the Dolphin.ini file and some SIDevice setting to the value 6 to fix this with RetroArch so it didn’t seem so complicated. That did not do the trick for me though…


#5

So I found a working solution for the built in Dolphin-emu core.

What I did:

  1. In the Dolphin.ini file like mentioned in the opening post I changed all SIDevice values to 6. I don’t know if this is required or if you guys only have to do step 2 and beyond. Now it works for me like that so I’m leaving the ini file like it is.

  2. Open a GameCube game running the Dolphin core and enter Quick menu in RetroArch (RA). Head to controlls selection. My idea was to set remaping per core, so also for Dolphin for my GameCube games as I don’t use Wii games. Configure device 1 or control number 1 like you want and make it perfect. I would recommend focusing on only one control at the start. Save core remap file when you are happy with control 1.

  3. Now, here is where I encountered problems before. I headed back into quick menu and then controls. Now, I am not able to configure control 2, 3 4 and 5 right? That was my issue in the opening post in this thread. I could however toggle the type of device for all of them, in example RetroPad. We will use device 2 as an exmaple here. I did notice that when I toggled device 2 control type that my device 1 key mappings were blanked out and device 2 keys became active. That was strange for me because I thought all of them should be editable and showing all the time on the screen. So… Step 4. Pay attention to what I said about setting up device or control 1 perfect first.

  4. Make a note of your settings for device 1 and in what order they come in.

  5. Toggle device 2 back and forth so you get the keys to go active for that device or control and leaving device 1 with blank keys (don’t worry).

  6. Configure device 2 just as you did with device 1.

  7. Now do the same for device 3, toggle type of controll on device 3. Now both device 1 and 2 will be left blank. Set up device 3 just as you did device 1 and 2.

  8. When that is done do the same for device 4 toggling control type back and forth.

  9. Now you did all four controlls with the exact same setup. Device 1, 2 and 3 should have blank spaces and only device 4 should be “configured” on screen with the correct key mappings.

  10. Now go and save core remap.

If you do follow these steps to the point reading carefully you will find when hooking up Xbox One controller 2, 3 and 4 that they actually have the correct key mappings now working with Dolphin built in emulator. Don’t worry that RA doesn’t show the mapping of all controlls. Trick seems to be to make the first control perfect like you want and then active one and one setting the same settings and at the end saving the core remap.

Enjoy! :slight_smile:


#6

@enurweb

Nice work! I’ve been struggling with this for half the weekend. Thanks for posting this solution. I can confirm it works!