[Android] Thumbnails on external storage?

Kind sir! I’ve read alot of your posts and I greatly appreciate your insight and vast RA knowledge. Apologies for tagging you via reply here, but as a new user, I do not believe I’m able to message you directly, let alone begin a new post/topic. Thank you for indulging me!

Wondering if you can shed some light on an issue I’m having- I’m using a 2nd gen firetv, and having storage issues on the device, as far as loading/using thumbnails goes.

I can use rhe online updater tool to pull in NES thumbs successfully, but I’m strapped for space to do any addtl consoles.

I’ve downloaded all desired thumbnail zips manually, and have unzipped everything I need. I’ve placed them on my USB hard drive, which is connected to the fire TV(where all ROMs are also stored).I’ve changed the directory tree in RA settings accordingly, and have tried to scan my box art folders using the add content function, to no avail.

How the heck do I get RA to pull in and apply thumbs to all my other ROM collections outside of using the online updater tool?

Many thanks in advance for your time!

Hmm, I don’t know if RetroArch is able to read/write files from external storage like that (thank Google’s bizarre “security” policies for that).

1 Like

It does work, I have my thumbnails on the SD card on my NVIDIA Shield Tablet and used @dlnp22 's method.

Maybe it’s a FireTV thing.


Thank you both for the quick responses!

It’s odd, as RA can read and add the ROM zips off the usb drive just fine. Frustrating, but I can live without the box art, I guess. :sunglasses:

Thanks again!

Metchebe, after you placed your thumbs files on your SD, how did you get RA to add/apply to your playlist?

Did you just set the thumbnail directory to that folder on your SD, and RA applied automatically, or did you have to hit the + icon and add the content by scanning the directory? (Hopefully that run on made sense :wink: )

Yes, I simply set the thumbnail directory to the folder on my SD card.

If correctly named, RA will show thumbnails for playlist entries, you don’t have to re-scan.

Sometimes databases change and thumbnails use old names, those need to be fixed manually (re-named).

1 Like

I am too having a hard time getting thumbnails to work from an external HDD. I should also mention I’m just starting to get the hang of using Romcenter to have a clean romset, but I don’t know if the names or formats are correct after that (which would cause in itself the problem of not loading thumbs). I moved the thumbs directory to the HDD because I’m on a 16gb nVidia Shield 2017, so required space would encumber the little premium real estate I have (and is probably why Genesis and Snes thumbs from the online updater repositories would never complete, no matter what).

Any thoughts on thumbs on external HDD as of 2019?

You might be able to get around the android permission issues if you name the folder accordingly on the external drive. There’s a similar issue for users of Kodi and they can get around it if they name the folder the same as the folder on the local storage. For retroarch it should be:


Then in your retroarch config, point to this folder. Naming the folder like this allows write permissions for the app.


And BINGO, that did the trick. I’m no programmer or expert, but come to think of it, it makes a lot of sense. Thanks a lot for your Swift reply, Zach!

Thank you!! this is what I needed, now finally I can use an external USB to save disk space on my Fire TV Stick 4K, everything works like saves files, savestate files, overlays, shaders, and so on, the only thing that don’t work are cores, I wonder if there is a way to use cores from the USB.

1 Like

I was having issues where retroarch was not writing any files to the folders I specified on my sd card. Changing the path as you suggested now seems to have fixed this issue. Now playlists and saves are being properly saved to the sd card! I’m still working out the thumbnails however, even after moving them to the new path and pointing retroarch to that folder. I’m wondering, should the thumbnails be directly in the thumbnails folder on android, or should each system have its own folder (ie: “thumbnails/Atari - 2600)” like it is on Windows)? I ask because I did keep the “system” folder names intact with each system’s thumbnails in their respective folder, but they still aren’t showing up for me. Otherwise, every other issue I was having with sd storage has been fixed by using the path you suggested.

Thanks, -George

The thumb path should follow this:


So then the updated paths would be something like:

          Atari - 2600/
                    Q_bert's Qubes.png
                    Q_bert's Qubes.png
                    Q_bert's Qubes.png

And then your retroarch.cfg would include:

thumbnails_directory = "/[your_external_drive]/Android/data/com.retroarch/thumbnails/"

Hi all. Thanks for posting this! I’m running into an issue with setting this up on my Fire Stick 4K. I’m following the thread closely, but where do I find the name of [your_external_drive] ?

Using ES File Explorer, I pasted my thumbnails directory into my external storage to this location:


(btw - 1005 will change to 1006, 1007, etc each time I unplug and reinsert my USB stick)

I’ve tried identifying the name of my external drive in ES File Explorer based on what’s shown on the screen, but its not working. Here’s what I’ve tried so far in my configuration file:

thumbnails_directory = “/UsbStorage/Android/data/com.retroarch/thumbnails” thumbnails_directory = “/storage/E5E5-1B06/Android/data/com.retroarch/thumbnails” thumbnails_directory = “/E5E5-1B06/Android/data/com.retroarch/thumbnails”

Perhaps someone who has gotten this to work can reply with what they used and I can work off of that. Thank you!

Just wanted to post an update that I figured it out!

I had to set the thumbnails_directory to the following, INCLUDING that last forward slash. My mistake that I didn’t include it originally. Thanks so much for your help. This is an excellent thread!

thumbnails_directory = “/storage/E5E5-1B06/Android/data/com.retroarch/thumbnails/”

I was able to figure out my external drive name using ES File Explorer.

This is a complete Newb question, but can you point me in the direction of a post or tutorial on how to change configuration files within Retroarch on a Fire Tv?

This post covers exactly what I want to do (move thumbnails to an external USB to save space on my fire TV), but I have no idea how to accomplish the tasks listed here. I’ve previously used a Raspberry Pi with retropie, and I used to plug a keyboard into the pi in order to work within the terminal. ON the Fire TV though, I’m unsure of how to accomplish this.

Thank you!

Thank you. This worked for me.

Is there any update for 2023? I have installed Retroarch on my Fire Stick 4k Max and I have set the thumbnail location to my usb drive, but it doesnt load the images! Maybe Amazon has disabled the write access to an usb drive if we launch an app from internal storage?

I have found the solution! Amazon Fire Stick only allows Retroarch to read files, but not to write files! So you have to download the thumbnails with Retroarch to your internal storage, copy the “thumbnails” folder to your external storage and then you have to change the thumbnail folder location in Retroarch to your external thumbnail folder! After that you can delete the thumbnail folder on your internal storage to save some space.