Any chance of upscaling in the bsnes core being applied universally?

Sadly, the new bsnes core doesn’t seem to apply resolution multipliers to games unless Mode 7 graphics are being rendered. For example, Final Fantasy III (6) has the Mode 7 resolution multipliers working for everything on the Mode 7 world map (which includes the lead party member’s character sprite) when using the core, but as soon as you open the menu or enter a town, the game will just revert the resolution back to native until you go back to the world map or fly the airship (both feature Mode 7 graphics). In the standalone bsnes emulator, resolution multipliers work in all situations for all games that I’ve tried; Towns, dungeons, and even the load game screen renders in high resolution. Is there any possibility that the bsnes core (which to my knowledge is almost a direct port from the standalone because of the libretro target) could mimic this functionality?

That hasn’t been my experience with standalone. I’ve been working with it lately to add the new shaders and it was only pushing increased resolution on screens with mode 7 content when I used it.

1 Like

I have some screenshots of the load game screen from v109 (, and I can confirm that the high resolution still works universally in v111. You do have to turn off blur under Shaders though.

I’ve been using v109, but here it is on non-mode 7 content with crt-geom:

and here it is with high-res mode 7 content:

Notice the scanlines aren’t really visible in the mode 7 shot, while they’re nice and chunky in the non-mode 7 one. That indicates that the non-mode 7 is still at ~240 height but it jumps up to higher (960 height in this shot) in mode 7.

@Hanlon299: If all that you want is getting rid of the blur, go to Settings > Video > Bilinear Filtering and make sure it’s OFF

1 Like

Didn’t realize it was that simple, but it worked. Thanks!

1 Like