Ares is becoming the best N64 emulator

New version just released and it fixes a ton of timing/speed issues. These issues have been affecting every single emulator or fork since the beginning of N64 emulation.

Are there any plans for a RetroArch core? Ares has multiple cores itself but we only really need the N64 one since all other systems have just as good or better RA cores already. But soon, the RA N64 cores will be obsolete, if we really want to play N64 games accurately.

1 Like

It’s been more accurate than mupen64plus-next for a while. I don’t think that “obsoletes” mupen, though, as it’s quite demanding (i.e., only appropriate for high-end gaming PCs).

That said, we would certainly welcome an Ares-N64 core, of course, but I think they’re happy doing their own thing in their own API/GUI. I/we are on good terms with them, so I don’t think there would be any real friction if someone were to libretro-ize it but I don’t think anyone on our end is in a big hurry to do so right now, either.


I’m unfortunately unable to extensively test it very much at the moment. For some reason anything using ParaLLEl-RDP no longer seems to work on my Windows installation at all (just goes straight into a black screen and/or crashes the program - happens with simple64, RMG and ares, though not Mupen64Plus-next, which is telling because it’s somewhat out of date and hasn’t incorporated some of the most recent ParaLLEl code). It DOES work on Ubuntu, but with VERY slow performance, so in the end it’s probably driver issues all around. In any case, I was able to ascertain, after enduring several minutes of worse than single digit framerates, that Donkey grabs the vine successfully in the DK64 title screen demo, which is usually indicative of very good core timings. Only simple64 at one point replicated this feat, though it has since regressed. I’m curious to see how it plays Knife Edge, which is one of the most famous edge (heh) cases for this.

yeah, they recently tightened some timings and it fixed a lot of stuff, including DK.

1 Like

Knife Edge still plays too fast.

However other games have been fixed, the demo/attract modes in Goldeneye, EWJ3D, Quake 2, etc seem to run fine now.

I dug out my desktop PC running Manjaro just to try it out. Indeed, the timings surpass anything on the other emulators. Even though Knife Edge still plays too fast, it does appear to slow down to the proper speed when there’s a lot going on. I also tested Body Harvest’s intro cutscene, which does show improvement as well, but it’s still too fast in several parts so the music and sound ultimately still desync.

I then tried OoT’s ending cutscene, which has emerged as yet another test case as of late. Most emulators play the Lon Lon Ranch scene too fast, so the music ends up lagging horribly behind by the time we see the sages up in Death Mountain. Ares actually has the opposite problem now: it ends up playing it a bit too slow. While the real hardware slowed down in several parts of the cutscene, ares slows down more than is necessary in those parts, leading to the music being ahead in several points (a good place to check is when Malon appears: she needs to start singing the moment she appears on screen). though it seems to almost even out by the end somehow. That said, the fact that slowdown actually happens tells me they’re on the right track.


Beetle adventure racing demo is a bit better, still not perfect.

Speaking of Beetle Adventure Racing, can you reproduce this bug?

  • Use the US version of the game
  • Select Single Player
  • Select Duel (any difficulty)
  • Pick the green car with the white stripes (you need to have this unlocked, it’s not available from the start)
  • Lastly, select Country Cove

When the camera reel starts, where it shows you the level, press start to stop it in order to start the race. The game will freeze or crash.

This happens 100% of the time in every emulator, every fork, every version, every plugin and every configuration setting. I think it might be a real bug that also happens on the real N64 but i don’t have the game there to test it.

Yeah it gets stuck on the race name screen in mupen next parallel-rdp.
You can still bring the menu up and hit reset, so maybe it’s not an emu bug.

Someone confirmed it happens on the real N64.

1 Like