Beetle PSX HW texture replacement testing & feedback

Hi folks,

With the new feature of Beetle PSX HW texture replacement , I wanted to test couple of games to see whats feasible and whats not.

First lets start with a few points:

-Those aren’t textures packs , Just testing for the texture replacement feature

-I used gigapixel for on all shown examples for convenience. which is not a great choice as it adds thick lines and loss details, certain esrgan models would have way better results , especially the trained ones

-The seams in the backgrounds games are to be expected, even the dolphin had them , the creators of resident evil 2 & 3 seamless HD packs used a clever method to overcome this. As for Chrono Cross , I think the creator used waifu2x for the backgrounds.

  • The main issue right now is the inability to grab all textures ,as it can be seen in metal gear (hit or miss), Tekken 3 (character portraits and other textures) Parasite Eve 2 & resident evil (only dumping mask layer)

Well without further ado

I’d also love to test this. I even already installed ESRGAN on my computer but I have issues to get the texture dumping work. Trying to find out why it doesnt dump any textures do I need the latest version of retroarch for this? I still use Retroarch 1.7.9 because I cant update it (its complicated). All I want to know is if my old retroarch version is the reason that is doesnt work or if I do somethin else wrong. btw how do you insert a new line?

1 Like

No texture dumping on my end either. Would OP share the specifics of making this work?

Hello folks , sorry for the delay , I just saw this.

1 - Ensure you have the latest core “mednafen_psx_hw_libretro”

2 - Before running the game , make sure to create 2 folders next to the game *.cue or *.m3u in this format

“*.cue or *.m3u name”-texture-dump

“*.cue or *.m3u name”-texture-replacements

any mistake in the folders name would make it not work Here is an example:-

another one for m3u

  1. make sure you’re using vulkan render ( it’s not gonna work with opengl or any other render)

  2. Run the game

  3. go to options and toggle “track textures”

  4. press F1 (go back to the game) and then press F1 again(go back to options)

  5. 2 new options should appear , “Dump textures” and “Replace textures”

If you you still run into issues , come over on discord

More experienced folks are over there , including the creator of the core feature

Wuhu its working now :smile: Thanks a lot :slight_smile: My fault was that I only created a folder [gamename]-texture-replacements, because in the news blog they say: “While the game is running, it will dump all current active textures it comes across to a directory. The name of this folder is [gamename]-texture-replacements, and it will dumped inside the same dir that your content (ISO or other image format) comes from.” They didnt say anything about the folder [gamename]-texture-dump. Someone should correct this blog. I’ve read a lot of comments on reddit and youtube that ppl have issue to get this work. This might be a reason

You’re welcome mate , yeah even on discord multiple people got the folders naming wrong.

It’s a new feature but folks will get used to it.

My main concern now is that the core is still unable to dump all textures. However I’m confident that within a year or two , awesome texture packs will be made for our favorite games :grin:

Ye I noticed this too. From playing for 2 minutes a game it dumped 4300 textures but only 35 of them are bigger than 1 px height. And I miss the textures of the start screen. Still I’m looking forward to this feature :slight_smile:

Okay this is awesome. Unfortunatelly it only dumped the texture of the main character but I already love this feature

internal resolution x2 without texture replacing


internal resolution x2 with texture replacing

internal resolution x8 with texture replacing

OK, first and foremost, thanks saeedalshaikhpygas for that concise tutorial. Regarding the actual issue that was occurring on my end, it was exactly this particular problem with folder names. To get to the bottom of the problem I opened a PowerShell window in retroarch’s base directory and opened retroarch using the following command:

./retroarch_debug.exe -verbose

The “-verbose” argument tells you everything retroarch is doing behind the scenes.

The relevant part was:

[libretro ERROR] failed to write to: D:\example\roms\Sony - PlayStation\example iso folder\relevant folder name-texture-dump\somenumbers.png

It’s interesting to note that, for my case, the game name was Resident Evil 2 - Dual Shock Ver. (USA) (Disc 1) (Leon) (Track 1).cue (or .bin) but the folder needed to be named Resident Evil 2-texture-dump (there’s no Dual Shock Ver. (USA) (Disc 1) (Leon) (Track 1)) so keep an eye on that.

Also, I, too, was confused by the wording in the news blog, so maybe that needs an edit.

Glad to hear it worked out mate, This has got traction real quick on discord . folks over there discuss issues they encounter and help each other . someone has already started silent hill texture project , one of my wishlist :relaxed:

Big thx for this :stuck_out_tongue: i would like to know if oyu know hw to fix this kind of issue on every background games

i tried Waifu2x esgran topaz manga xbrz etc ,

As I stated above, for the prerendered backgrounds games , this is to be expected due to the way the textures is stored.

you’re upscaling the tiles and chunks out of context.

The dolphin had the same issue with resident evil 2 & 3 .

The talented folks at https://www.reshdp.com were able to overcome this by doing the following:

1 they took the tiles and small chunks

2 assembled them to form a whole image

3 upscaled the image with gigapixel

4 de assembled the upscaled image in same tiles and chunks of the original

5 feed the upscaled tiles and chunks into the emulator

I believe that the assmbleing and deassimbling were done with the help of the pc versions of resident evil 2 & 3 .Gemini extracted some data of pc versions.

As for chrono cross , according to @slerp at discord (the pack creator) the dumping of the textures were done directly from the iso using a tool that was created specifically for chrono cross. So his method won’t work on other games.

1 Like

thx !!! im sorry :stuck_out_tongue: i just realy want i will test this way !

As for chrono cross , according to @slerp at discord (the pack creator) the dumping of the textures were done directly from the iso using a tool that was created specifically for chrono cross. So his method won’t work on other games.

How does this work? If retroarch didnt dump the textures how does it know which textures it has to replace?

it’s alright mate , I too wish prerendered background games upscaling.

Resident Evil 2 & 3 Seamless HD Project

final fantasy 7 SYW “ArkTsukiVock” (v4)

final fantasy 9 moguri mod

are some of the finest work out there . I certainly would love Resident Evil 1 ,parasite eve 1 & 2 ,legend of dragoon and more to follow. It’s certainly not out of the realm of possibility anymore .

I haven’t had the chance to go in detail with @slerp on this . your guess is as good as mine I’m afraid.

Ah okay, may I ask how you deal with transparency? My issue is that ESRGAN fills the alpha channel with black. So if I upscale this for example:

c7d60508-7190c14d

I will get this as result:

c7d60508-7190c14d_rlt - Kopie

And if I cut this black background off I have some rough outlines:

c7d60508-7190c14d_rlt

And if the background borders on texture parts which are black too I would accidently cut these parts off, aswell. :thinking:

yeah , the transparency and alpha were discussed multiple times on discord , I’m afraid there haven’t been a solution yet.

Someone on reddit told me to use the ImageEnhancingUtility.
If I compare the results of before and then

1aa2a733-a65721a0x2 1aa2a733-a65721a0_4x_FArtDIV3_Blend

The outlines doesn’t look much better but at least very dark parts like in this case the shoes dont get cut off anymore. So this tool seems to be better in handling transparency.
However if I test these textures created by this tool ingame I have the same issue as 1vierock:

If I open the texture with gimp it looks like full transparency but if I mark these areas which in the screenshot above are black gimp shows that there is somthing

Regarding the edges , I think this is supported to help

http://forums.qhimm.com/index.php?topic=18798.0