Beetle Saturn no longer running games

Hi,

I updated Beetle Saturn and now no games will run. I get the error: “uncorrectable data at sector 0” when I try and boot a game. It runs the bios but doesn’t go beyond the Saturn logo.

I have since done a fresh install of the latest version of retroarch, re-downloaded the core and ripped my game discs again. I’m making them from the original Saturn discs and have done fresh bin / cue files but still no luck.

I’m in the middle of a Shining Force 3 play through so will be grateful to get this sorted.

Thanks

Hmm, yeah, looks like something broke. I think I know the culprit, so it should hopefully be easy enough to fix. Thanks for the heads-up.

Brilliant glad it has been identified I’ll give it a try again after it has been fixed and report back.

Glad to see this Hopefully a Easy Fix.

As I have same Problem

Did the core get an update? Any chance its up to date with the standalone?

Looks like there was an updated core with yesterdays date. Not sure if it is up to date with Standalone version.

No, there’s no change vs standalone.

I have tried this now and all working like before. Thank you.

I have a question about Beetle Saturn actually. Is a frame skip possible for it? Mine runs pretty good but on occasion there’s the odd dip in frame rate that results in crackling sound. I know it’s quite demanding on hardware but just thinking of possible workarounds for things like this.