Beetle Saturn not loading games


#1

I am new to Retroarch only been using it about two weeks now. Everything seems to run fine for the most part. Until I tried to load a Sega Saturn game. They issue I am having is that Beetle Saturn keeps trying to play the game as an audio CD. says 22 tracks and nothing plays. I have the right bios that I need. Should I try another core or how do I know the rom/iso is bad?


#2

Yeah, that sounds like a bad ROM, but if you post a log, we can take a look: https://docs.libretro.com/guides/generating-retroarch-logs/


#3

Sorry it was a bad rom. Dot anothjer games to run no problem.


#4

Or maybe an european iso ? Every time i tried to load one, beetle saturn would fail.


#5

I will definitely check that out. Thanks


#6

PAL games totally load up in Beetle Saturn. I have the entire PAL set. I remember I had to find another PAL BIOS though.


#7

for the sake of documentation, could you post CRC32/MD5/SHA1/SHA256/SHA512 of the bios that worked with PAL content if its not one already in the .info?


#8

Do I need a tool to check that stuff or is there an easy place to do so?


#9

https://support.microsoft.com/en-us/help/889768/how-to-compute-the-md5-or-sha-1-cryptographic-hash-values-for-a-file


#10

@SkyHighGam3r And you can still load US games with the same bios ? mpr-17933.bin is used for both EU and US games, maybe only one or the other can work at the same time depending on the bios you set.


#11

Figured out how to get that game working. I had to use CDmage. It didn’t find any errors but after I saved it to a new file location with CDmage the game started working.


#12

@hunterk - I’m not following these instructions properly or something. I can’t get the command line to perform that function after installing that program to C:\FCIV

@BarbuDreadMon - Yeah, I just tested it a second ago too, just to be 100% sure. “mpr-17933.bin” loaded both Burning Rangers (NTSC) and Darius 2 (PAL) no problem.