Bettle PSX HW + MacOS + GL = Blank Screen w/sound

It looks like I’m experiencing the same blank screen issue that many people seem to be experiencing with Beetle PSX HW. I’ve come across countless threads with potential workarounds, and none are working for me.

I seem to recall coming across a thread which said this core won’t work with GL on Mac. But I can’t seem to find that thread again… if someone can confirm this is the case, please let me know.

As I cannot use Vulkan drivers in my case (old iMac, Radeon HD 5750 graphics) I’m stuck with GL or software. Software renders 1x just fine, but starts to choke at 2x, so I was hoping to use a hardware renderer instead.

Things I’ve tried:

  • verified by checksum that my BIOS files are present and valid
  • confirmed shaders are turned off.
  • Tried setting shared context ON and OFF; neither have any effect
  • Futzed with all of the rendering options in the menu.

Am I stuck here? Or is there some magic sauce that will make hardware rendering work? There seems to be reference to a version of Beetle PSX HW that used GL 3.1 instead of 3.3 that did not have the issue (not sure if this applied to MacOS). Does anyone have a mac compiled version of this core from before the 3.3 “fix”?

Alternatively, is there a libretro version of PSCXR anywhere? I had decent results using that standalone. (colour is a little dim/dark in places, but otherwise renders nicely at higher resolution than native). I’d prefer to use RA as I’m launching from Attract Mode.

Any help is appreciated!

  • Jeff
1 Like

GL renderer has some problems currently that I’m trying to track down. I’m getting black screens with Mesa (linux), too. The log is filled with “Renderer state marked as valid but state data is null”. I’m not sure if it’s an issue with RetroArch, the core or my drivers, though, or some combination thereof.

Thanks for the reply! I will wait for an update then.