Broken Shadows in MGS with Vulken

I was playing Metal Gear Solid, and I need to use the Vulken video driver because using OpenGL breaks other stuff in the game like the opening cut scene or codec calls. So I used Vulken over the other driver options. I recently updated both RetroArch and Beetle PSX HW and I am running in to an odd shadow issue that I never ran into in older versions. The Shadows look stretched and having this weird line pattern. Do you know why this is happening and how I can fix it.

Here are screen shots to show you what I mean:

and here is a link to my core settings for Bettle PSX HW:

Is it affected by PGXP settings?

I just tested it. All of the PGXP options turned off have the same result as with them on. It might be worth noting that OpenGL does not have this shadow issue, but as I said it breaks other major stuff like codec calls and the opening cut scene.

I just joined to search for a solution to this issue. I have experimented alot with the settings, and it seem any internal resolution above 2x causes the weird lines.

Are there any chance this will be fixed, or is it a limitation overall? I also noticed that it only seem to happen with HW, not SW. Software takes too much computer power to run at high internal resolutions anyway, so there’s no way around it.

Stumbled upon this thread, as I happened to be playing through MGS on Beetle PSX HW myself.

I’m running RetroArch 1.7.7, Beetle PSX HW core 0.9.44.1 e58fe03, and the 417.71 Nvidia drivers. I’m using the Vulkan renderer with a GTX 1070 under Windows 10 1809.

On my machine, I have no issues with funky shadows, and I am in-fact using 8x internal resolution. What GPU, OS and GPU driver version are you using Muyfa666?

1 Like

I have a RTX 2080, Win 10 Pro 1903 and nVidia driver v431.68. RetroArch v1.7.7. The version of beetle core downloaded from within RetroArch. I don’t know how to check which version of the core I’m using.

As a quick update, the weird glitchy graphics only occur if I run the game at 16x the internal resolution, at 8x it looks fine. It still is odd though because in an older version of the core I was able to run the game at 16x the internal resolution without any issues at all.

I tried the latest nightly. No difference. 1x and 2x works ok, but anything above that makes the graphics weird. :frowning:

Have the same issue as reported here: https://github.com/libretro/beetle-psx-libretro/issues/529 RTX 2080 here as well, but with driver 431.60. Tried RA 1.7.7, 1.7.6 and 1.7.5 with no luck. Can someone tell us how to compile the HW version of Beetle PSX? I’ve managed to compile the sources from https://github.com/libretro/beetle-psx-libretro but I only end up with the software version. Do I have to change more than one setting in the makefile?

Add HAVE_HW=1 to your ‘make’ invocation.

If this does fix the problem, please report back. Compiling from source is a mystery to me.

The following commit doesn’t have the same texture corruption found in the latest version: https://github.com/libretro/beetle-psx-libretro/tree/8a2bdba066e418f617567bfec256c66ff9ad3c2c

This instead though has constant audio ‘crackling’ and if you use PGXP you get some corruption on certain 3D models.

In order to manually compile from sources you need MSYS2 among other things installed. This guide helps you set these parts up: https://docs.libretro.com/development/retroarch/compilation/windows/

Once this is setup you just open MINGW and navigate to the dir where the source is located and run ‘make HAVE_HW=1’ and after a while you should end up with a ‘mednafen_psx_hw_libretro.dll’ file in the same dir. Copy that to the ‘cores’ folder where you have RetroArch and load it up.

Adding HAVE_HW=1 after ‘make’ is enough. Turns out the source I compiled had issues building correctly. Now I just need to find an older version that doesn’t have this issue.

Adding that argument to the make invocation or setting it to 1 in the makefile gives me a HW dll, but it only has the software renderer in the options.

So this one is clean and the next commit has the shadow problem?

If you don’t use PGXP it’s clean yes although I noticed it doesn’t scale the image correctly while underwater. However I don’t know when the texture bug from the OP was introduced. This was just a random test of an older commit from back in december.