Can you import DOSBox configurations from releases?

I’m new to DOSBox stuff in general, so please forgive my ignorance.

I’ve got the new DOSBox-pure core loading up games great, I was having some fun in DOOM 2 for a bit. So I started to convert my setup to using DOS zips instead of the releases I normally run for these titles. The first one in my list was Alone in the Dark. Loading it up in DOSBox-pure, it’s running a bit slow, missing music, and missing voice. SFX are present, however.

I know that DOXBox uses configuration files when it’s packaged with games like those at, and that same Alone in the Dark game on that release doesn’t have these issues. So I’m assuming it’s just a matter of setting configurations correctly in DOSBox-pure and saving them somehow.

My initial thought is that maybe I can take my release configurations - since they are already correct - and import them into this RetroArch setup somehow.

If not, maybe I can dive through the configurations and create RetroArch ones based off that, but I’m not sure where I’d be putting those files. Are they just core option per game files in RA? Or is this a /system directory thing. Maybe it’s a /save directory thing? I’m not sure…

GOG does a lot more than just configs. They get right in there and change the game itself in many instances. Upgrade the graphics, totally bypass protection, even fix errors and bugs that existed in the original.

The .conf files only store what PC components you will be emulating and the dos commands to load the game at the bottom. That’s all.

When you install one of these from GOG, are there actual dos assets in the folder? Or is it all hidden by some GOG container?

Too bad there isn’t a “PC Launcher” core! LOL

All too true, about how GOG does things and how cool it would be to have a PC Launch core.

None-the-less, I have to assume things like severe slowdown, as well as missing music and voice would be due to DOSBox being configured incorrectly, no?

From what I can tell looking at Alone in the Dark (GOG) it appears to have the DOS assets present and accessible. The root directory contains icons, launchers, and uninstallers for current windows. Followed by a folder for DOSBox, a folder for Alone in the Dark (DOS) and another for Jack in the Dark (DOS). Looks like it has all the old dos files in each of these.

I guess DosBox could technically be configured wrong… the .conf files are fairly simple though. Here is the conf file for Alone 1 from eXoDOS:

If you have looked at a bunch of these, you’ll notice these are the same settings most games use. svga_s3, some cpu timings… It’s just not that hard to replicate a 4x86 PC which most of these games run really well on.

I should note that I have never used “pure” before. But the eXo version runs great on the “svn” core:

I didn’t play very long but it had music and I didn’t notice any slowdown. Interesting about the dos assets in GOG though, I wonder if some of their “fixes” could be applied?

Ok, so part of the problem is the version of the game I was using. Some crappy ‘cracked’ version of the original floppy release (which straight up didn’t have the voice samples anyway). I switched to eXoDOS (didn’t know this was a thing until now) and now I’ve got sound and music and all that wonderful stuff.

Seeing this work, now I understand why my initial question was kind of silly… At the same time though, it’s still moving suuuuuuper sloooowwww. I pulled up a video of the game online to make sure I’m not crazy and seeing that… Armadillo? spin in 3D was so much faster than what I’m getting in DOSBox.

Comparing to the configuration file, the little I can read, it looked like it was using the pentium (slow) chip in GOG’s files… I tried that in the DOSBox core, but no change. I tried some other (all from eXoDOS) games; Crusader - No Remorse and Ultimate DOOM. They all run at good speed, so I assume there must be something I should change.

I tried extracting it to a folder and running it via the SVN core, just to see if it’s a ‘pure’ issue - but running INDARK.EXE just gives me some error about mounting the CD.

OK I figured it out.

I was playing with “CPU Type” when I should have changed “Emulated Performance” specifically to “486DX, 33Mhz from 1990 (13400 cpus)”.

DOS emulation, while not as bad as MAME (or MESS, ugh), is rather complicated lol. On the bright side, it looks like in this process we answered my initial question lol No way to import those configs to this setup.

As a side note, I never could find the .conf for the eXoDOS version of the game. Where are those at?

You should try the new Dos Box Pure core, announced recently, it can load zipped DOS games and even mount Isos inside these zips. The main goal of this core is being as user friendly as possible and even auto maps keys to gamepad and games that support gamepads as default. The ones I tried worked great, even some trickier like Time Commando which I only managed to run in the normal Dosbox using some specific commands from a mid 2000’s forum post. As of now it doesn’t even require the .conf file.

1 Like

Hahaha I think you missed the 2nd sentence in the first post Aorin :stuck_out_tongue: I’m on DOSBox pure haha. I’m really impressed with the core compared to other versions. Alone in the Dark speed issue aside I’ve gotten a dozen or so games now setup with DOSBox that I never could before.

Except Ghostbusters II, dear god I cannot understand why that keeps asking for Disk 2. It KILLS ME there is a unique Ghostbusters game I’ve never played and Venkman just keeps taunting me about “Disk 2” and I can’t even find documentation online for it… arrrgh.

Glad to see you still kicking around on the forums btw. I just re-visited your Philips CD-i post earlier today trying to figure out some stuff on that one today too haha.

1 Like

Totally missed it, I thought you were talking about the normal Dosbox core since you mentioned .conf files. I urge you to post your issue in the github I posted earlier, the developer replied me twice and solved both issues, one of them being the Time Commando not loading and prompting for the disc.

Also, still in Time Commando, it was slow at first, but changing the clock speeds and other performance stuff, it ran smoothly.

1 Like