Can't download v1.7.4, Error 404

I’m trying to download the latest 64-bit Windows 10 version of RetroArch, but I keep getting a 404 Error. When I check others, all versions appear to give the same error. It appears that the download links are broken for version 1.7.4

Yeah, we had a server snafu earlier today. You can download what’s currently available from here:

and it will be re-populating over the next couple of days.

OK. I’ll go with 1.7.3 until the re-populating is done. Thanks for the update.

Thanks for Answering so I know why stuff is Missing

Any progress here? I still get 404 error with all hyperlinks in the win 10/8/7/vista section

the 1.7.4 stable downloads won’t be returning. We’re planning to release 1.7.5 stable soon, though.

I only get 404 errors on the windows uwp cert so… I’m stuck until that’s fixed because nobody seems to have that file.

no one told you to “**** off”. We’ll get the cert re-posted but I don’t personally have access to the cert and I was the only one online while you were crossposting it in all the channels.

Also, just FYI, I’m the only one here and on reddit, so you’re just hassling me about it over and over.