General   Site feedback


Topic Replies Activity
About the Site feedback category 2 January 16, 2017
"My eyes!" 3 June 14, 2019
Dreamcast cores not working 11 June 9, 2019
Login not possible "from this IP address" 6 June 7, 2019
Easy to understand! 2 June 4, 2019
Thanks liberto 2 March 9, 2019
Paid Service (Not what you think) 2 February 7, 2019
Fix your website and server 5 December 16, 2018
I can only reply to topics, not to posts 3 November 15, 2018
I can only start new topics in near-empty categories 25 October 20, 2018
Can't download v1.7.4, Error 404 6 October 1, 2018
"Corrupted Content Error" 4 July 17, 2018
Error when trying to access the forums by typing its URL 3 May 25, 2018
Access my old account 3 May 16, 2018
The www.libretro.com blog homepage weighs 78MB! 3 February 12, 2018
Downloading Cores from the Buildbot 4 December 6, 2017
Forum: dark theme? 7 November 25, 2017
Fantastic Update! 5 November 24, 2017
Forum needs stronger protection from copyright bots 1 October 14, 2017
Forgot password e-mail not working 1 September 4, 2017
Can't create New Topic in Windows Devices Section 1 September 4, 2017
Wait for moderation of every post/reply? 10 September 2, 2017
"Installation Instructions" 2 July 6, 2017
Links to forum on buildbot pages are broken 1 July 6, 2017
How about a retroarch UWP app? 5 May 23, 2017
Buildbot has outdated forum links 1 April 4, 2017
Bump in thread doesn't change activity. Is it the normal behaviour? 4 February 1, 2017
I like the new forum 22 January 20, 2017