Setting up keyboard controls


i watched a youtube channel that tried to explain how to set up a controller for retro arch, that didn’t work.

i recently used the vice emulator, and i found that simple to set up and use for both a controller & keyboard.

i would prefer to use the keyboard with retro arch at the moment, so how do i do this?

i have searched youtube for tutorials on this, but cannot find aything at all.

i am slightly dyslexic, so i prefer visual mediums such as videos to properly understand, if possible.



settings -> input -> port 1 binds -> bind all. It will prompt you for retropad buttons (retropad is the virtual gamepad abstraction used in libretro) and you can press the keyboard key you want it to be mapped to.

RetroArch has a lot of default hotkeys that can get in the way. You can unmap them in settings -> input -> hotkey binds by navigating to the option you want to unmap and hit ‘del’ on your keyboard.

it’s a lazy friday evening indoors for me, so this’ll be a good time for me to try this out.

if i recall, when i tried to set up the 360 controller, there was a menu in the rom game where you always have to press f8 before getting into the main menu.

the default hotkey action in retro arch is screenshot.

as it stands, i will only be using f1 to f4. a,s,p,l & space bar.

here goes.

spent ages trying that.

hit save autoconfig file.

told “error saving autoconf”.

sorry, i’m losing my patience with this program. this is not even vaguely intuitive to me :frowning:

even if i don’t touch a key in the 5 second countdown, it decides to choose it’s own key anyway?!??


it also refuses to let me designate a corresponding keyboard key for ‘up’ on the d pad.

again, “why?”

are these “bugs?”

is it a botched installation?

this just does not make any sense at all :frowning:

‘error saving autoconfig’ usually is related to permissions. Did you install outside of your user path? e.g., C:\Program Files?

if you don’t press anything during the countdown it falls back to the default mapping. Press ‘del’ key to unmap something. You can unmap all of the conflicting hotkeys or you can use the “game focus mode” which is like keyboard and mouse capture. I think it’s mapped to “numlock” by default…?

well, i DID install it somewhere that was better for me.

so i shouldn’t have done this? :frowning:

oh well, i guess i know now.

i’m going to give tinkering a miss for the rest of tonight, i must confess it’s giving me a headache.

thanks for trying to help out, i appreciate it.