Dreamcast cores not working

So I updated to version 1.7.7, and for some reason both Reicast WinCE and regular Reicast crash. I find this strange, because I have both BIOS files required. Can anyone fix this?

They work fine, AFAIK. You’d need to post a log for us to even guess what’s going wrong.

Greetings, first port :smiley: For me the Dreamcast cores also aren’t working. I’m using Kubuntu 19.04, Kernel 5.1.5, Mesa 19.2 git padoka (R9 380X) and latest version of RetroArch and Cores (BeetleDC, BeetleDC-WinCE). The problem is that RetroArch freezes when loading a DC game. I have tried the following:

  1. Different gl drivers, GL and GLcore, GL1…
  2. Removing padoka drivers and back to stock (19.0.1 I belive)
  3. Oibaf drivers
  4. Stable RetroArch
  5. Unstable RetroArch
  6. Reicast, Reicast-WinCE, BeetleDC, BeetleDC-WinCE

The result is always the same, the boot process begins and it freezes at random, but never past the boot process. The only way to close RetroArch after that is by killing the process it self (or with Ctrl+Alt+Esc thanks to KDE power!) I compiled reicast from source and it worked like a charm. Redream has never worked for me :frowning_face:, so I can’t comment on that.

Here’s my log. https://pastebin.com/2F8AMjsa

I’m not seeing anything about the BIOS in there. Do you have all of that stuff in system/dc?

Yes, on that exact folder (~/.config/retroarch/system/dc). The same BIOS works on regular Reicast outside of RetroArch.

And as I mentioned, I can sometimes see the entire Dreamcast logo, other times, just some letters. It always freezes.

Should I change the verbosity of logging? That was level 1, I’ll give you level 0 instead. But it doesn’t look too different. https://pastebin.com/rcJsmYF8

Okay, so that’s the problem; I didn’t have the directory set up.

Well, thanks for solving my problem.

1 Like

I thought you had the same problem to me. Well… at least one of us has the problem solved!

Cheers OP!

I had a similar problem, troubleshooted (troubleshot?) the hell out of it (in two different installations on the same PC…):

  • Deleted Retroarch.cfg (didn´t work)
  • Tried a fresh install on another folder (worked)
  • Replaced the updated core with an older version (worked)

In the end, the newest core with 1.7.7 started working again when I removed the core´s options from retroarch-core-options.cfg (Windows x64, just for reference)

It never occurred to me to remove the saved core options from the .cfg file. I’ve been using the older Reicast and PPSSPP cores on the latest stable version of Lakka because I could never get them to load. I’ll have to give this a try when I get home after work today.

Edit: Nope didn’t work for me. Guess I’ll stick to the Reicast/PPSSPP version inside the 2.2.1 build of Lakka. I even tried the newer Beetle_dc core and it didn’t work either.

1 Like

What happened to the Naomi and atomiswave cores??? I had my system working not the cores are gone replaced by wince??? It don’t work anymore. Everything is the same my dc folder with bios. Nothing changed on my end. What can I do to get it working again???

There’s been several reports of random lock ups and they seem to be due to a Mesa bug, which makes the entire RA process freeze.

Upgrading or downgrading the mesa drivers might help.