Can't get 2 controller to work in BEETLE PSX HW

I tried searching the forum for a solution to this but couldn’t find it.

I want to use 2 controllers for playstation 1 games but only 1 is working.

I am using Retroarch 1.8.5 with the BEETLE PSX HW core on a Windows 10 PC.

I am using 2 Brook Universal Fight Boards as XBOX 360 controllers.

I am able to setup the inputs in core settings and save them but when I run a game only player 1 controller is recognized player 2 doesn’t exist.

I have attached images of my settings.

I have no problems getting 2 players to work with Retroarch for nes,snes,genesis,SMS or 3DO.

Also weird I rebooted computer now the controllers are being seen as xinput not windows 360 controllers, but in the other cores (i.e. SNES) it is recognized as 360 controllers.

How do I get both controllers to work for Playstation?

Thanks in advance

Can you post a screenshot of quick menu > controls > port 2 binds?

Hello Hunterk: Thanks for replying. I took a pic of both port 1 and port 2 binds.

Hmm, that all looks okay to me. Have you tried any other PS1 cores with the same games you’ve tried with beetle-psx-hw? like non-HW beetle-psx or PCSX-ReARMed?

Thanks for the reply,

I have tried what you suggested, HunterK.

And ran into new problems when I go to “Load Content” select a playstation cue file I get 3 results from the PS1 cores:

  1. BEETLE PSX HW: I get a black screen
  2. BEETLE PSX: tries to load then crashes
  3. PCSX ReARMed: Get a “Failed to content” message.

Where have I gone wrong?

wait, you were loading it fine in the other posts. What happened??

If you can load it in HW, it should load in non-HW, to… I guess we would need logs of 2 and 3 to be able to know what’s going on.

Well I was running Retroarch through Rocket Launcher. But when you suggested I try other cores I tried directly through Retroarch.

I tried looking in the logs folder in the Retroarch folder but it’s empty, what file do you need to look at and I’ll try doing a search.

Thank you for the instructions, I have attached 3 logs, one is BEETLE PSX HW, followed by the other cores. It’s quite a few screen caps I hope that’s okay as I can’t seem to attach anything but jpg,png, or gif. Additional info Retroarch sits on my D drive but I moved my PSX roms to my F drive.

would you mind copy/pasting the contents somewhere like pastebin.com? It’s difficult to go through screencaps.

An excellent suggestion. BEETLE PSX HW https://pastebin.com/5qSpLrc7 BEETLE PSX https://pastebin.com/V73tDwBN PCSX REARMED https://pastebin.com/6PGQKYVv

Thank you for all the help thus far.

1 Like

Ok, for the black screen on beetle-psx-hw, I believe that’s caused by a Cg/p shader. If you disable that, I think it should work.

For non-HW beetle-psx, it looks like it’s using the ‘dual analog’ controller type. Have you tried changing that to anything else?

[libretro INFO] [Beetle PSX]: Selected controller type Dual Analog.

For PCSX-ReARMed, that log looks okay except for:

[ERROR] Failed to load content

I’m not sure why that would be happening when it loads for the other cores, but there it is, I guess.

Thank you, Hunterk, for taking the time to look into this for me. But I’m afraid I may have made it worse as I tried to turn off the video shaders in BEETLE PSX HW Retroarch just crashes now as I load a cue file. https://pastebin.com/nc5eeDb5

ok, it looks like now it’s forcing the vulkan driver, which is fine, and it’s trying to load a core-specific slang shader, which I don’t actually see loading anywhere but that’s probably fine.

[INFO] [Shaders]: Specific shader preset found at D:\Games\HyperSpin\Emulators\RetroArch\shaders\presets\Beetle PSX HW\Beetle PSX HW.slangp.

[INFO] [Shaders]: core-specific shader preset found.

[INFO] [slang]: Compiling shader "D:\Games\HyperSpin\Emulators\RetroArch\shaders\shaders_slang\crt\shaders\crt-easymode.slang".

It doesn’t seem to be crashing. It doesn’t have any errors and nothing is failing, as far as I can tell.

I’ve attached an image of the last thing I see before Retroarch crashes and the log to go with it

https://pastebin.com/q30zvA4K

I am to run it no problems through Rocket Launcher; however, getting the 2nd controller to be recognized is still a problem. I have changed the input driver to dinput and changed input 1 & 2 from being “dual shock” to just “playstation controller” but player 2 still won’t get recognized in game.