Can't navigate RetroArch - <Controller> 'Not Configured'

I have been working on this for days and now I need to ask for help.

I have an Em95x Android TV Box. The goal is to use it as a retro gaming box. I downloaded and installed RetroArch from the Google Play Store. When I fire it up, I get a white screen with a bunch of options, but I cannot do ANYTHING on the page. I have a keyboard attached and it says “Not Configured” when I try to use it. I have an Xbox 360 controller attached and it too says “Not Configured”. I can use both of these devices with other applications, just not RetroArch. Mouse input does not work either. I tried two Bluetooth game pads as well and they both report “Not Configured” when I try to use them. All the Google searches I do assume that I can at least navigate the menus of RetroArch, but I can’t do even that.

The box reports itself running Android 6.0.1. My RetroArch.cfg is located at: /storage/emulated/0/Android/data/com.retroarch/files

The contents of the file are provided below are at: My RetroArch Cfg File

The autoconf profiles should be included in the main package, I think, so perhaps something went wrong with your installation process…? Have you tried reinstalling?

EDIT: if you’ve already tried that (or if you try it and it doesn’t help), you might try downloading the autoconf profiles manually from the buildbot’s web interface and then manually modify your retroarch.cfg to point to that location.

1 Like

I’m having the same problem with my Mi Box. If I use an older version (there seem to be general issues with the 360 controller in every version after 1.3.4), at least I’m getting the notification that the controller has been configured, but I still cannot do anything in the menu. I also tried it with mouse and keyboard and the Android Remote app (where it also says that is configured, but nothing happens). I do think that this is a general issue with managing inputs, not anything specific with the autoconfig - as there is nothing working at all.

For me too is impossibile to navigate. Set top box zidoo s9 with Android. When i start retroarch i see extracting base.apk but i can move nor mouse nor keyboard or controller. And if i check filesystem i can see only .cfg extracted no other files Regards

1.3.6 work. I can mve through menu level

I was able to partially solve my problem. I found where the autoconfig files are in my installation and took a look at them. In my retroarch.cfg file, the input_driver is listed as “Android”, so I took a look at those. I don’t see XBox 360 controller in there. I did, however, see an entry for a bluetooth controller I do have, and tried that one. It worked!

Its not an entirely happy ending. If I accidentally trigger an input from any of my unsupported controllers (such as my keyboard), I am knocked back to being unable to control anything. The only thing I can do is exit retroarch and relaunch it, being careful to launch it only with the supported controller.

I really would like to use my Xbox 360 controllers. Most of my Google searches suggested that since its been supported in the past. Other than retroarch, I am able to use the controller as an input device in other areas of my box.

i grabbed the latest nightly. i like the fallback feature. still cant use my xbox 360 controller. I thinks its because its not OEM. Its an Afterglow PL-3702. When I connect it, it says

100%: Android Gamepad (3695/531) not configured. using fallback.

since the controller is 360 compatible, can i copy the xbox config and change the IDs?

I copied the XBOX 360 Cfg and changed the vendor ID and the other number, as well as the display name. When I plugged in my controller, it was recognized and kinda worked. I will check out your link. I’m getting close!


My box reports Android 6.0.1

I tried that build and had similar problems. I have a NAS Box with Android (4.2.2), but QNAP didn’t bundle gamepad/joystick drivers, so it’s keyboard only. On 1.3.6 my keyboard (USB-HiD standard stuff) worked fine, but on 1.4.1 no luck (tried the custom build linked above, same problem).

RetroArch manages to detect the keyboard when I press the key Android understands as “Back”, but no other key (luckly, the “Home” buttons takes back to the Android homescreen). I tried plugging another keyboard, which also works on Android, but again, not on RetroArch.

Since it’s not a box I use for gaming, that doesn’t bother me, but I thought it might give some hint about what is happening.

Let me try and sum up my experience also with Android TV boxes. I’ve had official and third party 360 controllers working, PS3 official (can be tricky especially with the associated PS3 in range), I have an old PS1 to USB adapter and that worked. My friend has an old Microsoft Sidewinder and that worked. But this is all on the box I deal with most which is the Dolamee D5. I’ve tried to set it up for other people with different boxes and no success at all.

Today I was using 1.4.1 on someones box running android 6.0.1 and no luck with a Rocky Candy 360 controller, but I updated to the latest nightly and it worked, but after a bit would seem to almost disconnect and light up a different corner of the X on the controller then nothing would work again. Configuring it through input-> user 1 bind all, after that I could navigate but not select anything. The same thing is happening right now for one of my friends with the same controller on one of the D5 boxes. He can navigate but cant select anything.

It all seems so weird to me when you can control the rest of the OS but then of all things a gaming app wont recognize it? I use a Microsoft all in one wireless keyboard with the touchpad when configuring these boxes and I feel like it used to work to navigate the menus but now doesn’t, so I cant configure. This is another reason why I’ll always pick Windows over android all day and that is what I use for Kodi and emulation for myself. I’d still like to have some kind of concrete solution here. Basic menu navigation shouldn’t be this troublesome when you have various input devices present.

Im in the same Boat using Google Pixel C on Android 7.1.1. Retroarch as it is works like a charm, but i cant get to work a wireless xbox360 controller -.- And im out of ideas. I use a USB-C Adapter with the wireless Receiver. In Android OS the Controller works fine and in Retroarch it seems he detects the Receiver (going in “Input”). As @postwarbreakout mentioned it seems to partly working. at least left/right navigation but up/down is a mess. I tried different Retroarch builds , no success -.- I tried a MOGA Bluetooth Controller, works like intented. So yeah wireless xbox360 Controller support is the last missing peace for me

Edith: tryed a PS4 Controller wired - worked out of the box wireless (bluetooth) - partly worked (same proplem like the xbox360 wireless)

Hey guys my name is Ozzie and I’m new on this forum. I’m hoping someone out there can help me out. Long story short I’m trying to see if there is a way to configure a Steel Series Stratus XL controller to the Amazon Fire Stick. I cannot figure it out for the life of me. I know the controller is compatible with Retroarch because I can use the controller on my PC. However everytime I start up Retroarch on the Fire Stick I get the error message “not configured.” Any help would be greatly appreciated as I really don’t feel like purchasing another controller. Thanks in advance!

I’ve been getting the same issue with my previously trouble-free Mad Catz C.T.R.L.R (retail, not stock). It defaults to “Android fallback, not configured in port 0” where it used to just work fine before. So taking that lead I decided to configure it in the menus but it’s still not quite right. It now shows itself as Mad Catz C.T.R.L.R but occasionally Retroarch “forgets” I have it connected and I have to restart the app. This can just happen while navigating the menus.

EDIT: Also wanted to add that if the controller goes to sleep after a period of inaction, Retroarch will not recognise that I have reconnected it. On this pad you hold the Home button down for 5 seconds, and it then turns blue to denote connection. The light turns blue but Retroarch does not respond to input presses, and the app must be restarted. This does not occur on other apps using the same controller. If you require any further info please let me know. Many thanks.

Have you tried navigating to Online Updater>Update Autoconfig Profiles? Worked for me.

I’m trying to run this on the oculus go. They’ve recently allowed Android apps to run through its oculus tv, which is basically a screen in vr that is showing Android apps. Anyhow, I side loaded the most recent retroarch for Android. It boots up into a white screen. I can see a scroll bar on the right but I’m not able to scroll. I can only select the options that are visible. This works with my oculus controller, and Xbox one controller paired to the oculus go. Both are just able to select but no scrolling or navigation. I want to try editing the cfg files but I’m unfamiliar with this on the android file structure. I can see where it is installed I think. The two folders I’ve found on the file structure on the go (android) are an android /data /retroarch /retroarch.Cfg. This file looks promising its fully loaded with all sorts of stuff, it’s actually intimidating. The other folder is in the main directory called retroarch. It appears to be populated with many sub folders (states, config, saves, etc…). But none of these folders house any files. They are all empty.

Any ideas?

Yeah, the retroarch.cfg is what you’re looking for. Since you’re using a controller anyway, look for menu_driver and change it from “glui” to “xmb”. That is the normal menu that’s used on PCs and works better with gamepads/controllers.

Okay that converted it to the pc gui and I can see more menu but I’m still not able to navigate with the XB1 controller paired to the go. I know the controller is working because I can navigate the other menus of the go. Do I need to change something else in the CFG to get it to look for a xb1 controller? When I look in the input device it says “Android” and the one below says it too. Should it say something else like xbox 360 controller? Is there a list of the various options for the CFG file? That way I can mess around with it.

I’m starting to wonder if the oculus go is reporting the xb1 bluetooth wireless controller as something that isn’t defined in any of the controller configs that I’ve seen in retro arch library. I’ve tried all sorts of combination of Xinput, android, wireless controller, etc… Only the right bumper acts as a button click within Retroarch. With the right bumper I can select any of the options. I cannot navigate the menu to the right though. I can hold right bumper down and slide any menu upwards and that allows me to move down the menu, but I cannot move over to the configuration tab.

Hmm, yeah, sounds like an autoconfiguration issue. If you can hook up a keyboard temporarily, you can try going into settings > input > p1 input binds and manually bind your pad (you may want/need to disable autoconfiguration, in the input menu, as well).